BUG Galaxy Watch Studio

There is a big problem in the latest updates even in 1.8.1. So before i talk about the bug just imagine a scenario where you want user to single tap for changing image of the background and double tap to change the image of the Watch Hands. If you implement that type of logic in Galaxy Watch Studio it doesn’t do that it will work only for the sooner one not the latter it will be changing on double tap to Watch Hands but if you single tap for the background image change it doesn’t do that. I don’t know why but changing image work on one object only in a single project. So guys please have a look on that and solve this issue.

I doubt it worked as you imagine in any of the earlier versions.
No matter how many taps you assign to the elements, the tap sensitive element on top of all tap sensitive layers will always be the active one. None of those that are covered will react to your tap, the assigned number of taps, single or double, does not matter. I think this didn’t change at all.

1 Like

For me it is not working if i assign tap to change background and double tap to change the watch hands only one will work other will not. I am using MAC OS and that was the same thing with 1.8.1 and now with this latest one. I am not sure of older versions as i never used them tho.

Yes, it is like that, because the hand element completely covers the background, not because of how many taps did you assign to them.
You can read more about it here: https://developer.samsung.com/galaxy-watch-design/studio/tutorial/dev-button.html#Layer-Concepts-and-Limitations

Only the top layer can have button (tap) actions. And watch hands layers are for the full area they sweep across. So you have to design the background as full 360 x 360 the minute hand slightly smaller and the hour hand smaller still if you want to customize all three.
See the GWS Tutorial on set as button.

Having said that, this feature to be able to customize multiple items has been heard by the GWS Development team. I expect some fix to be done. They are doing there best to walk the line between being a simple to use designer tool, including useful features and staying true to the Galaxy Watch Use Interface guidelines.

Samsung Developer Program

Well it’s not like just for watch hands and bg. I created a watch face where i put a shoe vector image with black lines and when user tap it it suppose to be from black to white, and i created bunch of them as for different percentage of Steps like for 10% 20% and so on now what was happening is that when the steps level was on 0% that tap was working fine when it went to 10% it stopped working no matter how many tap i did shoe was not changing it’s color even tho i put that tap to change color on every picture.

Are you saying that you added an image, selected set as button then added images and only the first image changes. I put 15 images in change and they all worked. I’d need more information on how you set the button action.

Samsung Developer Program

No No, i am not saying that. Look how you create steps progress in time line ? by adding different images on different percentage of the progress. and with that every image there was image changing action, and that action was working with only first image not others. Me uploading SS of the project so that you may understand better.

OK I understand,
Only the top tap-able level can have a button action that is just how they work.

GWS looks the same as the old GWD but it sets some groundwork for other features. Hopefully this summer.

You have some good ideas for customization I like them.

Samsung Developer Program

1 Like

Thank you for your fast responses. I hope they add more features and also add this feature as well.

I just tried it for the battery complication, which works fine, i have tested upto 3 images on tap to change at different battery percentages in GWS ver2.0.0
Try it for the battery complication and let me know, cause if it works for battery it should work for the steps .

Did you test it on real watch or just on simulator that is attached to GWS ? if on simulator then it does work but if you test on real watch it does not. which sounds weird but that is what was happening with me.

Works for me on the watch too

Are you on MAC too ?

No I am on windows 10, maybe it is a Mac problem , though I doubt it

It might be a Mac problem as in Mac there are so many issues, Custom Fonts rendering issue not all ttf work and upon that if you work on a font and you save your project and you come back some time later and run it again and bang that font is not there it changes it to default one pain with that default is that you can’t change it again to the same font but if you compile and run that project it will show your custom font but on watch preview and on the GWS it will be showing default. Auto update never work on MAC either. IDK all of this happen in Windows too or just MAC