Cannot connect to run on device pixel watch

Seem to be having a sudden issue connecting to my pixel watch from WFS to run a watch face on my device. I was using WFS to design a watch face a day ago and it worked fine and ran on my watch, now all the sudden my watch doesnt show up

I double checked to make sure ADB debugging and wireless debugging are on in the developer options on the watch and also double checked the ip address was correct

When I run adb connect in a windows terminal I get an error with code 10061 cannot connect because the target machine actively refused it.

I even tried factory resetting the watch. Nothing seems to have helped.

If someone could help me with some direction Id appreciate it. It worked before now it doesn’t.

First off you can’t debug by Bluetooth anymore you need to debug wirelessly that has been the case for Samsung Watches for years and was added to an update to Wear OS recently

If that is what you are trying to do ignore the rest just connect by WiFi debugging.

If you are using WiFi

  • When you first enable ADB it asks if you want to allow it.
    You may have checked no by mistake
  • The first time you try to run on the Watch it asks if you want to allow transfer
    You may have missed selecting ok and don’t ask from this device again. This one will go away and possibly not be asked again.

In these cases go to the the ADB settings and be sure Wireless Debugging is enabled and if it is then next setting down is Revoke all Authorizations and do that. It will force any permissions to be re-enabled.

Samsung Developer Relations

Thanks for the reply

I wasn’t attempting to use Bluetooth I was attempting to debug over WiFi. I actually turned Bluetooth off on the watch to ensure it wasn’t for some reason trying to use that.

Watch face studio previously had worked without any issues running watch faces on my pixel watch. Yesterday that just seemed to stop and I have no idea why I changed nothing.

Currently watch face studio does not find my watch over wifi, despite definitely being on the same WiFi network as the computer watch face studio is running on. Like I said, previously I had no issues making this connection.

I did double check that ADB debugging was switched on and I did double check that wireless debugging was on on my pixel watch.

When I run a terminal window from the folder where ADB is located on my pc and try ADB connect (ip address of my watch):5555 as I have seen recommended on other forums I get an error saying the connection was “actively refused” by the target device"with an error code of 10061

Im not sure how to fix that error.

I believe if you revoke all permissions in the Developer Options setting. It will force you to accept the the file transfer option when you first try to run on device. I think you changed it to no at some time.

If that doesn’t help when you start adb in the Developer Options what is the ip address is it like ? the 5555 should be the port if that isn’t the port it may possibly be an issue.

Best of luck it is probably going to be something silly at least I hope so.

Samsung Developer Relations