Cannot run any samples in WFS

i installed and reinstalled WFS multiple times. every time i am trying to build a sample project i got an empty warning - and build is not successful. log in a dump folder is not very helpful - there are mostly errors like [printError(ErrorUtil.js:8)] Error: Error. ENOENT: no such file or directory, open ‘C:\Users\YEVGEN~1\AppData\Local\Temp.WatchFaceStudio\74236409484843861260561608478234\res\raw\wfs_e8b534ed_0ed7_44a0_8254_eab19da015a3_0.png’ Error: ENOENT: no such file or directory, open 'C:\Users\YEVGEN~1\AppData\Local\Temp.WatchFaceStudio\74236409484843861260561608478234\res\raw\wfs_e8b534ed_0ed7_44a0_8254_eab19da015a3_0.png

Please advice
Thank you

Generally when you go to build and get an empty or missing file error it is because

You location for the output to a missing folder make sure it doesn’t end with / instead if \

Your package ID is incorrect. It has to have at least 3 segments separated by a dot and they can’t start with a number.

You have the path to the keystore set to a folder not the keystore.jks file

the password for you keystore.jks is not legal
A valid password can contain 6 to 30 characters, begin with an alphabetic character, and use only alphanumeric characters and special characters like Underscore (_), Dollar ($), Pound (#). The password must contain at least one number.

If it isn’t one of them Delete the log and create a new one. either remove any personal information and upload it here or let me know and I’ll send you a private message so you can send it to me.

Samsung Developer Relations

thank you for a quick response.
i have two machines (one is mine and one that i borrowed for testing).

it works on other machine, not on mine,
i am looking in a main.log file.
i see that jks is created successfully on both machines.
build is started on both machines, however, on my machine is i see

[1.3.13][1/31/20231:36:02 PM][IpcMainImpl.(buildListener.js:69)] build start
[1.3.13][1/31/20231:36:03 PM][C:\Program(buildListener.js:130)] shared not complete

And this is the last line.

What can be wrong? BTW, i do install on default locations.

Thank you

Additional information:
com.watchfacestudio.cats (i am using sample)



main.log (9.9 KB)

See this path has more than one \ file separators and it can’t read and write to it.
C:\Program Files\WatchFaceStudio\tools\wfs_samples\Cats.wfs’

Watch face studio should be installed in
Not in C:\Program Files it is only set there if you plan to run WFS on the same computer from more than one account on that computer.

In your initial set up it asks for where you want the workspace to be and normally that is in
But you can have it anywhere that is writable
You can set that in WFS using the pancake menu upper left corner in Preferences.

Finally your jks file is incorrect you have to fill in something if it is NA for the country.

Samsung Developer Relations

i followed all your recommendations, however problem is still here.
Is it possible to create a verbose log?

Thank you

main.log (10.8 KB)

move the cats.wfs from
read only folder to your workspace

I think the folder is read only. As I recall in early versions it wasn’t and when someone updated it deleted their folders so it doesn’t allow you build in that folder.

When you see the javascript EPERM error it is an unable to read or write a file.

Samsung Developer Relations

you are correct that EPERM indicates read only files - i did not modified it since i want to use plain vanilla approach after installation
I removed reap only attribute from all files under WFS - EPERM error is gone and cats.wts in samples folder has been recreated.
build/cats folders were created also (but it is empty)
Unfortunately, the same problem still persist and i think that somehow it is related to a generation of aab and apk files

[1.3.13][2/1/20232:18:26 PM][IpcMainImpl.(buildListener.js:69)] build start
[1.3.13][2/1/20232:18:27 PM][undefined(buildListener.js:130)] shared not complete
[1.3.13][2/1/20232:18:27 PM][undefined(buildListener.js:131)]

latest log is attached

do you need versions of java, node etc?

Thank you

main.log (23.7 KB)

Your Keystore.jks file is wrong it can only be a 2 character country code.

I don’t know the decoding method but I think the country code and the user password are at least two keys.
for: CN=YK, OU=test, O=myorg, L=bg, ST=usa, C=usa


i will try,
but exactly the same key algorithm works on another machine that i borrowed for testing.
Do you know which part has buildListener.js:? i did not find it in distribution…i might give us some idea of undefined variable

thank you

i tried, the same error.
Actually, i think that app has a small bug - in a key generation country code is coming from state, con a country code = please take a look
i think that my problem is irrelevant to a key

Thank you

I overlooked something you wrote earlier

it works on other machine, not on mine

How old is your computer. We have found for some reason we can’t duplicate that certain older computer just won’t work. They meet all the specs but they just fail to build.

If your computer is an older model that is probably it and we are not going to fix it. However, if it is less than 5 years old I’ll try to help you.

Are you OK using regedit to clear the registry and restart?

Samsung Developer Relations

my machine is custom…i think i replaced MB couple of years ago. do you need detailed information?
and sure, i am ok to use regedit - any specific entries i need to remove of everything related to watchfacestudio key?

Thank you

I can find out but I think all the Watch Face Studio are obvious. If you want to be sure open a developer support request and please ask that Ron is cc’d on it. They can tell you what to do maybe even create a clean script to run.

I’d just uninstall WFS clean the registry and when you reinstall it, install it in the default
C:\Users\USERNAME\app data folder and not Program Files folder.

That way any paths used in Java script that are relational will be correct.

If it doesn’t build after that then I bet it is that unknown why some machines can’t build issue.

Samsung Developer Relations

Same problem.
The interesting thing is that error
[1.3.13][2/2/20232:29:24 PM][printError(ErrorUtil.js:8)] Error: Error. ENOENT: no such file or directory, open ‘C:\Users\YEVGEN~1\AppData\Local\Temp.WatchFaceStudio\51590411629740881260561608478234\res\raw\wfs_e8b534ed_0ed7_44a0_8254_eab19da015a3_0.png’ Error: ENOENT: no such file or directory, open ‘C:\Users\YEVGEN~1\AppData\Local\Temp.WatchFaceStudio\51590411629740881260561608478234\res\raw\wfs_e8b534ed_0ed7_44a0_8254_eab19da015a3_0.png’

That file does not exist, however, watchface.xml is here. That confirms that directory is writable.
I wonder when png file is generated…that may be a problem

does it run on AMD Phenom™ II X6 1075T Processor 3.00 GHz?

You are going to have to open a support request on this. This is something that engineering is going to have to look at. It works for me and it works on your other computer. The only .png it creates is the screen shot of the watch face. For the thumbnail image.


fair enough, i might do it later
my research consists of several parts - Android studio , WFS, backend services etc… i am trying to evaluate WFS and find out a way to port project to android studio- for potential additional code customization, usage of back end services, communication with connected phone etc.

Thank you