Cannot Run on Galaxy Watch 4 via Galaxy Watch Studio

I tried multiples ways to connect the Galaxy Watch 4 but had no luck with Galaxy Watch Studio. I started with a physical connection to the phone and bluetooth to watch but this failed so I moved onto direct wifi connection.

I ended up having to install Tizen Studio to successfully connect the watch. After adding it via IP and a nonstandard port, I toggled the connect to “on” in Tizen then hit “close”. Nothing showed in the Tizen device manager so I tired again. Still no luck. I decided to move on and see if Galaxy Watch Studio would work.

This is as far as I’ve been able to get. The device shows but nothing else happens when I try to run the face on the visible device.

This are screens from the watch to show I’ve enabled debugging and have wifi set up, I also restarted the device and my computer several times. There was a popup on the device and I selected the “OK” permission option.


For some reason I have also seen the bluetooth app open on the watch twice.

Any help on finally connecting would be much appreciated. I already tried deleting the permission files in the .tizen folder.

To make and side load watch faces for your galaxy watch 4 you need to use watchface studio program, not the GWS. Your watch OS is not supported by GWS. Its interesting you could actually connect it.

2 Likes

Thank you for the help! :sweat_smile: