Cannot use the Remote Test Lab

Hi,
I cannot use Remote Test Lab now. Always show the message:
“All ongoing tests have ended.”

I tried clearing the cache, opening in private mode, use another web browser but nothing helped.

Thanks,

That’s strange because I would think there are fewer people using the RTL now.

I don’t use it anymore because I would have to change my account to use 2FA. And because I log in multiple times a day, 2FA gets old really quickly :frowning:

What site are you accessing. They are doing maintenance and some sites are down or under maintenance. These are actual devices and they have to be manually set. Each Device farm may have hundreds of devices that need to be reset and many routers.

Select a different site if possible.

If this continues to happen let me know what site you are trying to access.

Ron
Samsung Developer Relations

Thanks for your response.

I’m accessing this site:
https://developer.samsung.com/remotetestlab/devices/101/galaxy-mobile

For now, I cannot start on any devices :frowning:

What site are you trying to access? They are doing a rolling update to each site and have to manually reset each test device after the updates so they look available but aren’t. If you can tell me which site I can try to find out what the issue is but generally they are back online within a few days.

Ron
Samsung Developer Relations

Sorry, I can’t get it. What is the site?
I tried to access Remote Test Lab via this website:
https://developer.samsung.com/remotetestlab/devices/101/galaxy-mobile

I tried to use any devices from anywhere: India, Korea, VietNam, USA, UK, Brazil, but no one worked.
Here is my step by step:
step.zip (955.7 KB)

I hope it helps!

Here is my screenshot what phone I booked, and what happen when I open thems


@YellowSprint

Have you got 2 factor authorization set up for your Samsung Account? RTL requires 2FA now. Since this seems to be wide spread that is all I can think of.

If that isn’t it then try an incognito Window and see if that works. If that does then clear your cache and try again.

If that doesn’t work then I need to know the exact time and sites you tried.

Ron
Samsung Developer Relations

Try from incognito. If it works, delete the cookies, the cache, the app data. I have to periodically do this such that various Samsung sites work well.

It has to do with the way the single sign on works between sites and how they are cached.

Ron

Hi,

  1. I turned on 2 factor authorization
  2. Tried with incognito Window but not work.
  3. Tried with VPN => not work
  4. Tried on other device => not work

Today, I tried again then I open the console log. I saw some error message:
Seem like this is the website Remote test lab connect
https://kr-gumi21-rtl.developer.samsung.com/device/R3CT40XQB8H

it always return the error 401
{“statusCode”:401,“error”:“Unauthorized”,“message”:“Missing authentication”}

Where did you enter the 2FA in the RTL site or in Samsung.com site? Before you “send” be sure to click remember this device so you don’t have to do it every single time. (but you will every time when you are in incognito browser).

It may be that it takes a day for the Samsung.com 2FA to synch up with RTL

Ron
Samsung Developer Relations

Hi, I did enter the 2FA in Samsung.com site. Where can I put the 2FA in the RTL?

I entered the 2FA for a week.

It will ask you to sign in before you can start doing tests. Be sure you are using Chrome Browser.

This is a holiday in the US so I can’t check but I believe what you need to do is go to samsung.com and sign out. Then go to the RTL and sign in and that should trigger the 2FA and the authorization will work.

If it doesn’t let me know if you can sign in using an incognito browser window.

The All ongoing tests have ended seems to pop up when the device farm is under maintenance and goes away once the device gets reset. That is a separate issue that I will bring up again with the RTL team manager I am making a report for them this week.

Ron
Samsung Developer Relations