Can't login to Remote Test Lab

When I login to RTL and go to All devices page, it shows Sign Button and I can’t select any device with notification “Please sign in if you want to use the Remote Test Lab service.”

If I click on the Sign in button, page is just reloaded.

The error from browser console:
GET 401 (Unauthorized)

Tried from another remote PC, located at another country.
The same result.

I’ve asked the RTL team if they have had any other occurrences of this or can determine a reason for it.

I’m no good on deciphering browser data I cleared Browser data and that didn’t seem to help. I will clear all browser data and see if that makes a difference. at the end of the day.

Samsung Developer Relations

I was just trying to get into RTL and I got a Dutch translations (lol) for 403 FORBIDDEN, both through my home network and 5G hotspot. I’ve never been able to use RTL, are they just having growing pains over there or is it something in my network settings?

Do they have a forum? I couldn’t find one

You aren’t the only one, I got the same error too. I had to delete 4 weeks of browser data to get it to work correctly again.

There are two issues with RTL one is someone crashes the device and the RTL team doesn’t know it. The other is they are gearing up for Smart TV RTL and that is taking manpower.

This is the right community forum for RTL issues.

Let me know if the clearing the browser cache for a month fixes it or not.

Samsung Developer Relations


I had to clear 28 days of browser data to get it to work correctly for me. After that it has been working.

Give that a try

Samsung Developer Relations

I’ll try as soon as I can and I’ll report back. Thanks Ron, for your tireless support!

By the way I can tell you why it does that. I was told that there is a bug, where every time it goes from the RTL site to the two factor login verification and back the length of the cached header gets a bit longer, until it is too long.

Samsung Developer Relations

Et viola! After following your instructions, everything seems to be working, at least to the point where I can log in and start selecting resources. I haven’t actually tried running tests yet, I’ve been busy with other things but I plan to work with RTL more seriously over the current holiday season.

Your explanation of the problem makes sense, are they planning to fix the bug or is this just going to require the cache-delete workaround?



I hope they resolve it, it isn’t just the RTL, I get it often because I do a lot of searching for solutions.

Samsung Developer Relations