Can't connect Samsung Watch to GWS - tried everything

Is it just me or is GWS and the Samsung connection process absolutely impossible? In a world where things should simply connect and work, I have spent 10+ hours over four days trying to simply connect my watch to GWS and utterly failing

I’ve tried connecting via WiFi, using my S20 as a hub, connecting through the phone and USB, setting debugging and developer options on, rebooting watch, PC, phone 100+ times

I’ve switched from a custom to a standard watch face. I’ve downloaded the latest USB drivers. I’ve deleted the files in the hidden tizen folder countless times.

I’ve tried with bluetooth on and off. Wifi always on and auto. PC + phone + watch all on the same 2.4GHz network from my home wifi hub

I can connect the phone to GWS (it identifies my phone as a connected device) but the watch is never connected despite sdboverbt connecting between my phone and the watch. Entering the IP address of my watch into RUN ON DEVICE draws a blank

I’ve tried connecting using command prompt SDB CONNECT and the IP address. I can ping the IP address of my watch, but it won’t connect. When I run SDB DEVICES my phone shows but not my watch

Why does this have to be so ridiculously complicated and frustrating? I just want to put a gws watch face on my brand new expensive watch and Samsung makes it totally effing impossible

The issues began when GDPR and US Privacy regulations went into affect restrictions are deliberate to keep unwanted hackers from accessing your devices.

Once you connect you will say why was this so hard. But there are a couple gotcha’s

When something you try fails restart computer and reboot watch. Turning a computer off (especially a laptop) and restarting will not always clear caches.

If you have a Tizen 5.5 OS you can’t connect via SDBoverBT it is an OS issue and is supposed to be fixed in the next software update.

If you have Tizen 4 your mobile needs to allow USB Debugging on your mobile developer settings to connect via SDBoverBT

If you have a firewall on your computer it may be blocking data transfer even if they connect.

You need to disconnect your ethernet cable even if you are connected by WiFi in my experience it works on occasion but more often than not I have to disconnect cable or disable the adaptor.

Debugging by WiFi have WiFi always on. Turning bluetooth off when in Auto is a pain to remember.

The one thing you didn’t mention was that you have accepted the RSA Encryption key if you don’t accept it the system thinks it is being hacked and does not show this again. Rebooting (holding down the home button until it says rebooting) should force this but not always.

You need to wait 60 seconds after restarting a watch to be sure it is fully connected to WiFi even when it says it is.

Deleting the hidden sdb files should have forced a new RSA Encryption Request.

If you don’t see the RSA Encryption key and accepting it download Tizen Studio Just install one Watch SDK don’t bother with everything as that can take hours. Then run Device Manager and it will force the RSA Encryption key even if you didn’t accept it.

Hope this helps if not let me know what watch you have.

Ron
Samsung Developer Program

Hi Ron - many thanks for your patient reply - it’s much appreciated

I accepted the RSA when I first connected my watch (Galaxy Watch 46mm) with my S20 phone usingthe sdboverbt app on the phone. Despite 100+ reboots/restarts (and clearing the hidden tizen folder) I haven’t been asked to accept it again

The laptop is a Dell Latitude E6440 running Windows 7 Enterprise (64 bit) and Java 8

I’ve turned my firewall off completely - SDB DEVICES doesn’t locate my watch at all over wifi, despite the laptop and watch both being connected to by phone as a wifi hub

It finds my phone when connected to the laptop by USB but lists:

the serial number, “unauthorised”, “device-1”

I can connect the watch to my phone using sdboverbt (would a screenshot be useful)?

I have tried to install Tizen Studio a number of times but it fails to install. The version with IDE installer gets to 46% then throws an error about not finding something. The CLI installer version just throws an error immediately. I have over 2 GB free space

Two more hours wasted. I simply can’t understand why this is so difficult!

Hi Ned,

This shouldn’t be that hard especially with the Galaxy Watch 46mm Start:


Watch connected to sdboverbt and computer

Watch Connected to sdboverbt but not computer

Good connection tap on watch
sdb over bluetooth 2

Do you get the connection from mobile to computer?

Ron

Also I forgot to ask. When you plug the USB cable from the computer into your S20 does the allow data transfer pop up? I think default is media only and you have to change it.

Ron

Thanks Ron

I have Watch Connected to sdboverbt but not computer - not sure what to do to correct that

I’m selecting the data option for the USB connection with my phone - I can explore the phone’s folders from my laptop

In your phones settings enable developer Options and be sure that the USB debugging is enabled.
Settings > About phone > Software information then tap Build number 7 times. If presented, enter the current PIN, password or pattern. From the Debugging section, tap USB debugging to turn on if off.

Ron
Samsung Developer Program

Developer setting enabled on both watch and phone
Accepted USB debugging on the phone when connected via USB to the laptop
Debbugging is on for the Watch 46mm, Wifi is always on. Bluetooth is on

Closed the GWS programme.

Cleared the .tizen folder again

Restarted laptop
Rebooted watch (Tizen 4)
Restarted phone

GWS will connect with my S20 phone via USB - but not the Watch 46mm:

screen 01


screen 03

On attempt 16,647 I am connected!

Thank you Ron - fingers crossed I can repeat it

Hi Ned,

Hopefully you have no problems from now on. It seems to work forever until you do an update. Then sometimes the reconnect issue.

When I do SDBoverBT and I get everything connected but the watch doesn’t show, Just restarting GWD usually works. But sometimes I have to restart phone, watch and computer. But that was rare.

Ron
Samsung Developer Program