Not able to connect My Galaxy watch to galaxy watch studio

I wanted to test watch faces on my galaxy watch but it doesnt connect even though debugging is on, on both my phone and watch. Tried all solutions like restarting, connecting without bluetooth and even resetted the watch. Please help me. And when I use sdboverbt, the watch notification only asks to connect to bt device(88ba4cfe) and doesnt ask to verify ant RSA signature.My phone is A71.

Screen_20200925_1458341

Sorry I do not have any good experience with connecting GWD over BT. Did you try Wi-Fi?

Did you enable USB Debugging on your Phone as well as allow file transfer. (The default is media only).

It may not be possible from your device Try using WiFi. You can use your phone as a wifi hotspot without being connected to the internet.

Ron
Samsung Developer Program

I have tried that too but my watch. Watch doesnt connect through wifi

yes doesnt work even through wifi tried mobile hotspot too

Do you have the Wifi connection set to Always On or is it just set to Auto. If it is Auto then it will never connect.

Copy the IP address down and manually put it in the GWS dialog box for run on device.

Ron
Samsung Developer Program

i tried doesnt work nor my galaxy watch asks for accepting RSA signature

Do you have a Galaxy Watch or Galaxy Watch3? Galaxy Watch3 does not work with the SDBoverBT that comes with GWS 2.0.

If you have Galaxy Watch SDBoverBT should work what is your computer do you disable the ethernet when connecting and only use WiFi I have to do that.

Ron
Samsung Developer Program

laptop is HP pavillion x360. I have n ethernet connected. Its only wifi and its GALAXY WATCH

And pls tell me how to completely remove Galaxy Watch Studio, so that I can reinstall and try again, I did uninstall and reinstall several times but noticed that some configs remained the same.

I’m having a similar problem, albeit with wi-fi. GWS stopped connecting to my Active2. Try submitting a support ticket with Samsung. They are offering me suggestions, although nothing has panned out yet.

In my case, I specify the IP of the watch, and when it tries to connect, it shows half of the IP address. Are you getting the same result? It will then immediately say “No compatible device.”

connecting_to

I, too, have tried to uninstall and reinstall GWS, and even tried the older ver.1.8. Before uninstalling, I copied my “workspace” folder over to another drive location for safe keeping. But upon reinstall it immediately offers the same projects. I believe this is because there’s the other folder which does not get uninstalled:

C:\Users\ [user_name] \GearWatchDesigner\

My next try will be to uninstall, then delete this folder, then retry, but I’d rather wait for Samsung support’s directions.

Developer support is here:

Active2 was updated to Tizen 5.5. this week was yours? If so the issue is you need to create a new Distributor Certificate.

Ron
Samsung Developer Program

If you Galaxy Watch does not ask you to accept the RSA Encryption key

  1. Close Galaxy Watch Designer Studio
  2. Reboot your watch (press and hold the power button until you see the word “Rebooting”).
  3. After the message that shows your watch has reconnected to the network disappears, wait 30 seconds.
  4. Click Run on Device in GWD and click on Scan devices. Keep your watch nearby and active. Wait for the RSA key screen to display on the watch and acknowledge it. It is reported if you start out with a factory installed watch face it works better.

If that doesn’t work

To Force a new RSA key acknowledgement
Close Galaxy Watch Studio

If you are on windows (10 for example) go to your “Users”-folder of the logged in account and search for a “.tizen”-folder. There are 2 files in it called “sdbkey” and “sdbkey.pub”.
Delete those files or move them somewhere.

Important Restart your computer don’t just turn it off and back on.

Restart your watch

If doing SDBoverBT restart your mobile

Wait one minute after everything restarts.

Ron
Samsung Developer Program

That won’t work no matter what you do. It will not connect if the ethernet is enabled it has to be WiFi to WiFi. Unplug the either net or temporarily disable the ethernet adapter. Both Computer and Watch must be forced to use WiFi if there are alternate methods such as BT for Watch or Ethernet for Computer.

I can help you with SDBoverBT if that is the issue Open a different thread if you want to try that again.

Ron
Samsung Developer Program

Hi, I’m looking in the forum for my answer about the problem, if I can’t find it, I’ll send you a guide on how to do it.
Regards
Robert

In order to get a new Distribute certificate I need to connect to the watch first, or enter a “Connected Device ID”. Since I cannot connect the device first, how do I get the required ID?

Hi everyone,
I hope this guide can help you, it has always worked for me on Windows PC.

  • On the Smart Watch
  1. Settings.
  2. About Watch.
  3. Software
  4. In Software Version Touch 5 times repeatedly until it says Developer Mode Turned On.
  5. Touch the top button of the Smart Watch to return to the About Watch page.
  6. On the About Watch page scroll to the bottom, you should see something that says Debagging is Turned Off / On.
  7. Leave pressed the power button until it says Galaxy Watch Rebooting.
  8. When the device restarts go to the Settings.
  9. Connections.
  10. Wi-Fi.
    10-1. (Wi-Fi and Wi-Fi Networks will appear)
  11. touch where it says Wi-Fi and select Always on
    12- Then touch where it says Wi-Fi Networks and connect to the same Wi-Fi network of the PC / Laptop.
    11- When connected to the same Wi-Fi Networks, touch the name of the Wi-Fi and copy the IP Address on a piece of paper.
  • PC/Laptop
  1. Download Tizen Studio.
  2. Install Tizen Studio.
  3. Open Tizen Studio.
  4. At the top tap Divice Manager As shown in the image.

  1. When it opens, touch where it says Remote Device Manager as shown in the photo.

  1. Touch where it says Add Device as shown in the photo.

3

  1. In the panel that will open, insert the IP of the Smart Watch that you copied on a piece of paper, then add a name that you like the most and touch add, as in the photo.

4

  1. then touch ON / OFF and Close as shown in the photo.

5

  1. It should appear as in this photo, then minimize Device Manager and Tizen Studio.

  1. Open Galaxy Watch Studio.
  2. Open any Project.
  3. When the project opens, touch F9 or Run on Device as shown in the image.

7

  1. It should automatically appear to you, as shown in the photo.

8

Note: After doing all these steps the Smart Watch should appear, if it appears, if so you can close Tizen Studio and Device Manager.

Regards
Robert

Thanks Robert. The Tizen Studio installation immediately asks for the location of the SDK, and without that location the installation will not proceed.

Update: Got it. Just had to create an empty folder first.

Update2: The Device Manager gets this error when I press the ON/Off switch:

tizen-device-error2

ok, if you have a problem with something you don’t understand, tell me I’ll help you

at least now we know that there are 3 possible problems, let’s check the first one.
Make sure you have the Galaxy Watch Studio serrated while connecting the Smart Watch and retest.
If the above did not work, check that the port is 26101 and try again.
If it does not work, you must buy that the IP is correct, you can check that the PC sees the IP of the Smart Watch, in the Start menu write cmd and with a right click open it with administrator permission, once open write ping (IP of the Smart Watch.
example: ping 192.168.1.1
remember to send a screenshot of what appears in each test.