Can't turn developer mode on on Samsung Freestyle

hi
i cant turn the developer mode with a 12345 thing in the apps
i use original remote

I have no idea about the projector but with Smart TV you have to turn it off (not Standby) and back on to “set” Developer mode

Ron
Samsung Developer Relations

soo… i’ve unplugged and turned back on - no
i’ve turned off by pressing the power button on the remote for a lil, unplugged and turned back on (i saw a house icon i guess that was a sign of a complete off) - no
is there even a developer mode on the projector?
i know that tizen os is tizen os on whatever samsung smart tv but what if…

@eliza

I believe that Samsung Freestyle is a SmartThing Smart Hub device They have their own SmartThings Portal and Developer Community. You will get more information there.

I only know enough about SmartThings and programming Smart Hub Devices to direct you to that site.

I hope you find the needed information there.

Ron
Samsung Developer Relations

@eliza
I actually was looking to do the same thing.

To get into developer mode, you have to:

  1. go to Samsung Apps
  2. hold the home button on your remote to pull up a digital number pad
  3. input ‘12345’ then done

This should bring up the developer mode toggle. Note that you will need to use the same digital number pad to enter the IP address of the host.

Good luck!

1 Like

I was also having the same problem and was only able to activate developer mode using a bluetooth keyboard.

Hi
I have problem with login to the Remote Test Lab and can’t create a New Topic.
Click on “New Topic” button throws the error in browser console: Uncaught TypeError: t is not a function

I have problem with login to the Remote Test Lab

This happens frequently you sign in and it verifies and then returns so the header that you don’t see is pretty long… Then the browser caches it and next time it it twice as long, and so on. If you can log in with a new incognito window then you need to clear your browser data and it should work.

If that doesn’t work there are some other things we can try but 9 out of 10 times it is the long header issue.

and can’t create a New Topic. Click on “New Topic” button throws the error in browser console: Uncaught TypeError: t is not a function

This was supposed to be fixed last week, I’ll ask the support team to fix it again. You need to go to Forum Home and create a new topic from that and then use the pencil on the title to move it to an appropriate forum.

I hope the incognito browser window works, and my apology for the inconvenience of the New Topic issue.

Ron
Samsung Developer Relations

Thank you for the response.
I tried everything. Clear browser history, incognito, PC (Chrome, Firefox), Mac (Safari). Nothing works (

GET https://developer.samsung.com/remotetestlab/rtl/api/v1/users/me 401 (Unauthorized)

This error in browser console occurs on all pages following the “Get Started” button.

“Sign In” button just refreshes the page as I’ve been already logged in.
If I select Device it shows notification “Please sign in if you want to use the Remote Test Lab service.”

I get something similar myself from within Samsung Network but not from my home computer. It is some firewall or something that Samsung network has set. I get Error 403 Forbidden :slight_smile:

Can you try from a different network and see if that works for you. If not then I’ll see if I can find someone with an answer .

Ron
Samsung Developer Relations

Tried from another remote PC, located at another country.

The same result
GET https://developer.samsung.com/remotetestlab/rtl/api/v1/users/me 401 (Unauthorized)

That really helped!!
Thank you so much!!:scream:

P.S. for dummies like me: do not open search bar after opening the Apps. Just hold the home button and type the numbers😁

Can you go the Forum Home and select new topic there and repost this. I’m trying to work with the RTL team to see what would cause this but it is hard to track when this is mixed in with the other topic.

Unfortunately I can’t move this to a new topic in Discourse.

Thanks
Ron
Samsung Developer Relations

I’ve already created new topic