Tizen OS Samsung TV UN43AU7000 doesn't let me enable developer mode

I tried everything and anything, It didn’t come with the option of developer settings…

What can I do?

I need to test some apps I’m working with, model UN43AU7000G

I have to ask did you read the instructions on connecting on this page?
Getting Started Page The trick is after you set the developer mode to On you have to reboot the TV (usually unplugging it for 5 seconds)

If that doesn’t work, some users have said they needed to use an external keypad to enter the numbers but others said they didn’t.

Hope this helps.

Ron
Samsung Developer Relations

Hi,
nothing works so far,

1- Tried with external keyboard
2- Tried rebooting
3- Tried with the keyboard on the remote control
4- Tried searching developer mode on settings
5- Samsung support was not able to activate it

Thanks,

Are you connected to the WiFi I don’t think it will go into developer mode if it isn’t connected to the WiFi.

If it is connected to the WiFi does it show in Tizen Studio Device Manager?

Ron
Samsung Developer Relations

Thanks so much for the help,
Yes, I’m connected to Wi-Fi and with internet, without being online Apps menu does not open.
It doesn’t show in Tizen Studio Device Manager, it’s not detected automatically and when manually typing the internal IP it has, tizen studio returns error while trying to connect.
I tried typing 1,2,3,4,5 inside apps with the remote and with an external keyboard, it just doesn’t do anything when I finish, no popup or modal shows at all, same if I type 0,0,0,0,0 the tv just ignores it.


Software version 2101

I don’t know why you can’t enable developer options. For hospitality smart TVs how you do it is different but you appear to have a commercial version and I don’t know of any other way.

I couldn’t find anything in any FAQ and it isn’t a Tizen Studio issue.

What I suggest is to ask this in the 1:1 Q&A in the Smart TV Seller Office that is where they do the Smart TV Developer Support.

Ron
Samsung Developer Relations