Conflicting APK problem

I’m developing an app but, after some successful tests, I started running on this issue: if I try to install a new APK my S20 shows this “app not installed as package conflicts with an existing package”.
I’ve uninstalled the app; uploaded it to the play store and tried to download it; tried clearing both Google Play Store and Services caches; resetting the phone; but nothing works.
Does anyone know how to fix this?
Thank you in advance!

Hello ronaldo.tribo,

Welcome to Samsung Developers Forum.

Please make sure that the application you are trying to install does not have the same package name as any existing applications on the device. You can check the list of installed applications and their package name using the ADB command: adb shell pm list packages
If a user application exists with the same package name, please make sure to uninstall the correct application first. However, if it conflicts with a system application, you might have to change your application’s package name.

Hope you will be able to fix the issue soon. If the issue persists, please feel free to create a ticket on our Developer Support channel.

Best Regards,
Mobassir Ahsan
Samsung Developer Relations.

Hello, Ahsan! Thank you for your reply!

Indeed as you said, we followed your instructions and found out that the package was installed on the Secure Folder. By uninstalling the app that was inside the secure folder we managed to install new updates.

Thank you for the assistance!