Connecting watch 5 pro to WFS

I just got a Watch 5 Pro. I downloaded WFS from Samsung’s site (Watch Face Studio downloads | Samsung Developers). I was able to import a watch face that I had made for my Gear S3 with GWS, and then build it. That went fairly well.

Next I tried to run that on my new watch. I followed all the instructions to connect: (on the watch) enable debugging; enable debug over wifi; in WFS, clicked on “Run on Device”. Then I got the pop-up for connected devices, and that didn’t show any devices. I entered the IP manually, but WFS couldn’t find it. Finally, after googling all afternoon, I found this link: https://adbinstaller.com/. I downloaded and extracted the zip file, then I ran, from a command prompt, “adb connect xxx.xxx.xxx.xxx”. After that, my watch showed up in the WFS connected devices. From there I could load my watch face, and as they say: “voilà!”, it runs just as it did on my Gear S3. At that point, I ran “adb disconnect” to disconnect the link between the watch and WFS. So all seems well.

My real question is: why do I need to run “adb” manually every time I want to upload a new face? Is there something I missed when setting up WFS? Or perhaps is something missing from the WFS download?

Any info appreciated.

TIA

ken

You never needed to do this.
The adb is installed as part of WFS

On Watch Settings - Developer Options - ADB Debugging (Allow it) - Debug over WiFi
wait about 30 seconds and it changes from not available to show the wifi enabled and your watch IP address followed by .5555 (the port for debugging)

If you are on a local network like 10.0. something it doesn’t search that low so you do need to enter the IP one time. When you do it will say no device found … look at your watch and you have to allow debugging select don’t ask for this computer again , or just click OK if you aren’t going to be running on device often.
Then it will pop up and you can use the WFS Run on Device.

Hope this helps.

Ron
Samsung Developer Relations

1 Like

I also NEED to use adb tool manually before being able to upload faces to my galaxy watch 5 pro…
Else, I never have the security prompt on my watch; even when putting its IP.
With manual adb command, the prompt appears on my watch; and then WFS is able to found it.

Thanks @daytooner for the tip !

Hi Cyril,

Be sure you have the latest version of WFS 2.0.26 (oops 1.2.7) there was a bug in 1.1.12 version where you had to restart WFS after the first time Run on Device (every time after boot up of the PC)

When you connect through WFS you do use the adb tool the only difference is you have to enable it in the watch first. Maybe you didn’t install it in the same folder as WFS expects it

C:\Users\USERNAME\AppData\Local\Programs\WatchFaceStudio\tools\window
(copy the address as text from file manger using right click on the address bar)
Open a command prompt
navigate to the folder address
cd C:\Users\USERNAME\AppData\Local\Programs\WatchFaceStudio\tools\window
Then type
adb connect 192.168.x.x:5555 (where 192.168.x.x is your watch’s IP address).
It may take a minute to connect or give a failure response
If you get a rejected error or something check your watch debugger settings.
Try in developer options to revoked permissions and force new acceptance. do the connect again.

Ron
Samsung Developer Relations

Really is version 2.0.26?

2 Likes

Thanks for the catch

1.2.7

Ron
Samsung Developer Relations

2 Likes

Nothing wrong, just wanted to correct