Do/could/should we have a compatibility/known issues list for studio?

I’m currently designing for and have to test two different watches a Samsung Galaxy watch 6 47 mm and an original pixel watch.

For the most part I haven’t noticed many issues with the Samsung Galaxy watch. 6. Except that when I place a picture, text or other item on the watch face in the studio, it is in a slightly different place than where it was when I run it on the watch.

But for the pixel watch I am having an issue where complications do not work at all and I’ve noticed that there are multiple reports of issues with the pixel watch.

I think a pinned thread or some kind of compilation of compatibility issues specifically for the pixel watch would be good to have.

Personally, I noticed that regardless of the complication type I selected it never displayed properly on the screen. Some complications didn’t display at all. Some displayed as the wrong complication. An example of that is if I wanted a text the circle completion bar like you’d use in batteries and an icon. I can have all three but I can’t just have one or two. The top it all off the complication with all three was under the wrong complication heading.

So something seems to be seriously wrong with complications and pixel watches.

But when it comes to the rest of it I was able to get most of my watch design on the watch and with a custom complication I was able to display some data that I wanted to show.

One problem I noticed other than complications directly is that let’s say you set a piece of text to display the current battery percentage. What will happen is if you set a complication then the custom complication that custom piece of text that displays battery percentage or that reads the battery percentage will then just read 100% regardless of what the actual battery percentages.

I also think a compatibility list of features for non-samsung devices is necessary. I actually do have a Samsung tablet but I don’t have a Samsung phone but of course I have my Samsung watch paired to my Samsung phone and not my tablet. It’s kind of frustrating, but it appears that some features aren’t compatible with the phone for no other reason other than to compel you to buy a Samsung device. And while I’m sure that’s common between manufacturers and some of the features aren’t necessary, it’d be great to be able to understand exactly, isn’t working the way I want, so I can decide whether or not pairing it with my tablet would be a worthwhile endeavor versus my phone.

Think this is due to the preview is 450 x 450 for 45mm watch. And scaling is done when on the watch 6

Are you sure u are “selecting” correctly? Clicking on a layout is not selecting its only for preview. You need to “x” it to really force to the layout u want.

You could also try hiding elements u dont need

Btw it could also be the pixel complication doesnt support that specific layout. When u first choose a complication type it allows multiple layout for different complication, and its up to the complication to decide which in the list it supports. (Make sense?)

Anyway see this guide…

What do you mean wrong complication heading?


What will happen is if you set a complication then the custom complication that custom piece of text that displays battery percentage or that reads the battery percentage will then just read 100% regardless of what the actual battery percentages.

Tags do not update in the work window but do in the run window (watch emulator.)

When you use the tag [BATT_PER] for battery it is constantly updated
for example in text box
Battery is at ([BATT_PER]) %
shows as
Battery is at 88 % on the watch.
Try using the Tag [BATT_PER] as the value a progress bar Here is one with a linear progress bar with the text above it.


You’ll be hooked on this soon enough.

What version is your Mom’s Pixel it if isn’t the latest it may not be as compatible There was an issue with older Pixel smart watches that their output was Text and not numeric and didn’t work right with the WFS tags.

Samsung Developer Relations

1 Like
  1. what do you mean set a piece of text? Tag expressions?

  2. set a complication? What has it to do with the tag expression text? Is this complication a separate element? Or your custom text is part of a complication slot

But @r.liechty_SDR is right about the preview vs work window btw

If you set text to display the batter percentage for a complication. The text becomes 100 after you choose what complications you want on the watch.

Meaning it’s running on my watch the value displayed for battery will show 89 for example. I start choosing my complications for other slots and the value now shows 100.

So it no longer shows battery percentage after a complication is set.

That has nothing to do with actually running it on the watch where it’s facing the issues.

It’s the first pixel watch. It’s been updated to the latest version. But it’s not the pixel watch 2.

I’ll try again and see but I spent hours trying to get it to work and it just wouldn’t work properly once it was actually on the pixel watch.

Hi, so u do see the percentage on the complication its not missing as i thought? But the percentage is stuck at 100%

Maybe its the pixel not compatible, can show the wear os version number?

What the values with [BATT_PER] tag

@Ceroes try [BATT_PER] along without % etc

See if it works. If it doesn’t then something wrong with wfs and pixel compatibility.

If it does then it some syntac error

You can see the percentage on the complication. It displays the correct percentage UNTIL you customize the watch face complications or add new ones. Then it just shows 100% always.

I will try the ta as soon as I can

Hi, probably watch issue.

A couple things.
I don’t think you can pair the Watch with a tablet unless that tablet has phone call capability not even the LTE version.

The text in Watch Face Studio is just exemplar and probably may show up in the Watch Face image when you are doing customizations on they watch or mobile but they will not install with that text or percentage. Do not expect what you see in WFS to be the exact same thing as is on the watch.

There used to be an issue with older Pixel watches the used a string instead of a number Those didn’t work with Tags and complications very well. I think this is fixed in new Pixel Watches. This may be the issue you are seeing.

Not all complications support all of the types that is they may or may not have an icon and the Title or Text may be backwards from what is shown in WFS.

Samsung Developer Relations

1 Like


The problem is what I was stating was occurring on the watch NOT on the watch face studio.

Possible although that sounds like it would have been or should have been resolved with a software update on either end. The Pixel watch is a original Pixel watch, not the Pixel Watch 2.

This was simply being tested on the battery complication. Again the TEXT though not the bars worked perfectly fine before you hold down the watch face and customize other complications.

Are you deleting the prior installation before running on Watch You might even try to restart the watch as well. Other than a Caching issue I can’t explain it.

Samsung Developer Relations

I did restart the watch I didn’t delete it before I reuploaded I can try that though

Or create a new project. It could be cache problems

If you restart your computer (not shut down and start) that will clear any caches . Just closing the WFS project will delete the temp work folder where everything is cached. The only time I’ve heard of where creating a new project was necessary was when the computer crashed with WFS open :slight_smile:

The cache I am thinking of is the memory optimization for the watch face on the watch.

I think you might be thinking of the missing assets issue some reported last month. That turned out to be because they updated an older project without updating it to the WFS 1.3.13 version first.

Samsung Developer Relations

@r.liechty_SDR Hi not sure about that but remember the case where the watch didnt get updated even when the file on wfs was changed (the moon case). I had to help the user delete and import the moon phase again for it to get updated.

Or file corruption (could be missing assert )instead of cache…but version use 1.5.7

So whatever the issue is its not only version 1.3.x


Yes that is the thread I thought you were referring to.
In that thread the issue turned out to be they went from a project created with WFS 1.2.x or older to 1.5.7 by-passing 1.3.13. I agree it is a bug, but in the project updating format. That is why creating a new project in 1.5.7 resolved it.

An issue that involves complications when you don’t remove the watch face between run on device is also a bug maybe in ADB maybe in WFS and maybe in the Wear OS but it has been reported often.

Samsung Developer Relations

1 Like