Complications cannot be configured through the Google Pixel Watch app

Complications that are added to the watch face can not be configured through the Google Pixel Watch app.

Tested with the latest version of the Google’s Pixel Watch app (, version (Sep 5, 2023) in combination with the Watch OS 4 Preview emulator that comes with the latest version of Android Studio Hedgehog (2023.1.1 Beta 5) and Watch Face Studio (both latest versions, 1.4.20 and 1.5.7).

Complication only has the “Empty” provider available in the Google Pixel Watch app:

Complications can be modified without issues on the smartwatch:

Watch faces that come with the emulator do not have this issue.

Steps to reproduce the problem:

  1. Create a new watch face in WFS (tested with 1.4.20 and 1.5.7 – both have the same issue) and add a complication.
  2. Run the watch face on a Wear OS 4 Preview emulator.
  3. Install and run Google Pixel Watch on the smartphone, pair with the emulator, then try to modify the complication settings on the smartphone.

I don’t know if this is the problem of Wear OS 4 being a Preview/Beta version, or WFS. But, maybe you guys at Samsung will know. Any response would be much appreciated. At least, so that we know whether this is just a bug of the Preview emulator that can be ignored, or is that something that must be fixed in the WFS.

1 Like

What watch are u using?

No physical watch. I am using Wear OS 4 emulator that comes with Android Studio Hedgehog. (

Think i cant be of much help. Because there is no issues using a physical samsung watch. And samsung wearables. Beside google pixel.

OK. Thanks for the info.

Hi. I just want to let you know that this is also an issue on Pixel Watch (1) with Wear OS 4 installed.
Watch face is made in WFS v1.4.20.

Hi. If you can, please comment under this issue

State, that same thing also happens to you on Pixel Watch 1 with Wear OS 4 and also write all software versions you’re running. (see from original post)


Seems that I do not have access to that issue…

I can open it with the private tab. Are you signed in with Google?

For some reason I can only visit this page in an private tab… Tried with multiple Google accounts with no luck…

Any chance you have an iPhone?

Nope, using Windows 11 on Firefox and Chrome

Strange, it should be visible to Public. Maybe try signing in in Incognito if it works. I know it’s a bit of additional work but for the sake of bringing the issue closer to fix :roll_eyes:

I used another Google account, it worked. Posted comment :smiley: