Error launching TV emulator on Win 11 "-enable-whpx: invalid option"


I’m running Tizen Studio 5.0 on a Windows 11 Pro PC. When I try to launch the TV emulator, I receive a popup error message “-enable-whpx: invalid option” and the emulator does not launch.

What I’ve checked so far:

  • my CPU supports virtualization
  • virtualization is enabled in BIOS
  • Hyper-V windows feature is on

Any advice?



You are doing better than me as I can’t even get Window Emulator to launch with a new version not updated version of Windows 11. Open a Smart TV Seller Office support request if you can.

If you aren’t a Smart TV Seller Partner let me know or get no reply let me know and I’ll see if the Tizen Watch support team can help.

Samsung Developer Relations

Hi Ron,

Thanks for the reply. I am going to try again on a different PC and see if I get better results. If not I will pursue a ticket.

I am not yet a Smart TV Seller Partner, but if I can get my app to work on Tizen, I’ll be in a position to sell 100s or 1000s of TVs. Can you share information on how I might be able to become a partner?


paul {at}

Go to this page first. There are several links there you probably should read before applying. One of the links is for the Seller Office where you apply to be a partner.

Becoming a partner is pretty easy but you can only sell in the US initially. You join a public group with and are assigned a Samsung group leader and then upload your app and if approved it gets a trial in the US. After than you can apply for global.

I do not know much about the Tizen Store but apparently you can distribute on that too.

With the certificates you can always install on your own or side load onto TVs on your network.

Samsung Developer Relations

Hi - I have exactly the same problem, except both on Windows 10 Pro and Windows 11 Pro

“-enable-whpx: invalid option”

1 Like


Go to your SDK data folder and then into "\emulator\vms\T-samsung-7.0-x86" there you can find the vm_launch.conf

In the section “[[QEMU_OPTIONS]]” there is the command “-enable-whpx”.

If you delete this command the machine will start however I cannot guarantee that it will work because I am still stuck in the kernel boot myself.

Thank you for the suggestion, but as in your case, the emulator gets stuck while booting the kernel.

I followed the installation instructions carefully, but I think this must be some kind of misconfiguration in the devkit. I am using Visual Studio.

Are you using Windows Hyper-V or Intel HAXM?

Also it seems that there are problems with AMD processors:

Hi @Elten, thank you for the suggestion. I am experiencing the same result as you - the emulator launches but becomes “stuck” after the Booting the kernel log message.

I was able to get the emulator to run on a much older Windows 10 machine. Here are the steps I followed, not sure if they all are required or not, but they worked for me:

  1. Install Oracle JDK 8u361 x64
  2. Turn off Hyper-V in Windows Features
  3. Reboot
  4. Install Tizen Studio 5.0
  5. In Package Manager, install Baseline SDK and TV Extensions-7.0
  6. Open Emulator Manager, create a TV 7.0 VM and launch it

FYI, this particular machine is running Windows 10 Pro 10.0.19045. Also, when I run systeminfo from a command prompt, the last four lines of output are:

Hyper-V Requirements:      VM Monitor Mode Extensions: Yes
                           Virtualization Enabled In Firmware: Yes
                           Second Level Address Translation: Yes
                           Data Execution Prevention Available: Yes

Some blog posts I read led me to believe it is important to have these four Yes’s.

All that said, I would really like to have this running on my primary workstation, which runs Windows 11 Pro 10.0.22621, so I’m still open to suggestions on how to get this working.

Thanks again,

Now I am using HAXM. I was able to get this to work on Windows 10 PRO by following the instructions here:

In my case it appears that the NX bit was the big problem.

I am also using Windows 11 Pro on a Surface 7, and following these instructions, I used the “Core Isolation” security settings tool to disable virtualization-based security, as described here, which did the trick:

Don’t forget to load the Intel HAXM driver from here:


1 Like

Thanks @Pavlos, were you able to get the emulator running on Windows 11 Pro? I followed the steps you mentioned and was able to install HAXM 7.8.0. However, when I launch a TV emulator, it hangs with its last log message “Booting the kernel.”

Hi - Yes, I was able to get it work on both Windows 10 Pro and Windows 11 Pro.

In my case, I never removed the “-enable-whpx” option as suggested by @Elten. I guess that might be something to note.

I spent three days on this problem, it’s non-trivial and there is very little information on it, and Microsoft has tried to lock down (or make it difficult to change) a lot of security-related settings.

I followed all the details given in those links to the letter. Make sure you use the Intel Processor Identification Utility to see that the virtualization features are all available. The emulator won’t work until ALL the check boxes are shown as “checked” in that tool.

Good luck.


Thanks, @Pavlos, for the encouragement. I was finally able to get the emulator working under Win 11 Pro. Details are here: Error launching Tizen TV Emulator on Win 11 "-enable-whpx: invalid option" - Stack Overflow

I think that in addition to everything you did, I also needed to disable an HP-specific BIOS setting (Virtualization Based BIOS Protection) and turn off several HP Wolf Security features.

Agreed that I did not need to remove “-enable-whpx”

Best of luck with your project!

On AMD I tried everything here but nothing works on Win 11, I have a Ubuntu VM on my PC, so I installed Tizen on it and after setting below VM configuration it does allow the emulator to work.

I know not a solution, but is easier to setup a VM then install another OS on the PC.

As far as I can tell with the AMD chip it is hit and miss if the emulator will work.

there is some discussion on the and if you search the Smart TV and the Galaxy Watch for Tizen Forum

You might find some help for settings.

Hope you have good luck and please report here if you do.

Samsung Developer Relations