Unable to launch Tizen TV Emulator

Hey guys. First time developer here.

I’m trying to create a small web app for my living room TV.

However, when I go to test it in the Emulator, it does not launch properly. The TV border window and on-screen remote appear, but don’t do anything. The logs are… weird, to say the least. 99% of emulator.log just consists of “Trying to vcpu execute at eip:000000000100016c” over and over again, filling up the file extremely quickly (to the point where Notepad++ asks to reload the file every time I tab over to it).

Here is an abridged version of the log (omitting all the copies of the same message):

18:07:25.049|17940|I|    osutil| 396|Running with elevated integrity level. Try to respawn.
18:07:25.056|17940|I|    osutil| 427|Respawning success. Waiting for child process.
18:07:25.080|15552|I|      main| 345|Start emulator...
qemu args: =========================================
"C:\tizen-studio\platforms\tizen-7.0\tv-samsung\emulator\bin\\emulator-x86_64" "-drive" "file=C:\tizen-studio-data\emulator\vms\BeanTV\emulimg-BeanTV.x86,if=none,index=0,cache.no-flush=on,id=drive" "-device" "virtio-blk-pci,drive=drive" "-drive" "file=C:\tizen-studio-data\emulator\vms\BeanTV\swap-BeanTV.img,if=none,index=1,id=swap" "-device" "virtio-blk-pci,drive=swap" "-enable-hax" "-device" "vigs,backend=gl,wsi=vigs_wsi" "-device" "yagl,wsi=vigs_wsi" "-smp" "1" "-m" "512" "-device" "maru-virtual-tuner,system=ATSC,country=USA,table=C:\tizen-studio-data\emulator\vms\BeanTV\tuner_default.cfg,stillimg=C:\tizen-studio\platforms\tizen-7.0\tv-samsung\emulator-resources\images,wsi=vigs_wsi" "-net" "nic,model=virtio" "-net" "user" "-chardev" "file,path=C:\tizen-studio-data\emulator\vms\BeanTV\logs\emulator.klog,id=con0" "-device" "isa-serial,chardev=con0" "-device" "virtio-serial" "-L" "C:\tizen-studio\platforms/tizen-7.0/tv-samsung/emulator\data\bios" "-kernel" "C:\tizen-studio\platforms/tizen-7.0/tv-samsung/emulator\data\kernel\bzImage.x86" "-append" "vm_name=BeanTV video=LVDS-1:1920x1080-32@60 dpi=72 clocksource=hpet consoleblank=0  host_ip= console=ttyS0 model=4ksero yagl=1 force_pat" "-device" "virtio-maru-touchscreen-pci,max_point=10" "-nodefaults" "-device" "virtio-maru-esm-pci" "-device" "virtio-maru-hwkey-pci" "-device" "virtio-maru-evdi-pci" "-device" "virtio-maru-motor-pci" "-device" "virtio-maru-keyboard-pci" "-rtc" "base=utc" "-M" "maru-x86-machine" "-soundhw" "all" "-usb" "-vga" "none" "-device" "maru-external-input-pci,stillimg=C:\tizen-studio\platforms\tizen-7.0\tv-samsung\emulator-resources\images,wsi=vigs_wsi" "-display" "maru_qt,rendering=onscreen,resolution=1920x1080,dpi=72" 
18:07:25.080|15552|I|      main| 348|qemu main start...
18:07:25.085|15552|I|emul_state| 733|initial display resolution: 1920x1080
18:07:25.085|15552|I|qt5_consol| 171|display density: 72
18:07:25.293|15552|I|qt5_supple| 515|* Qt version (compile time): 5.6.0
18:07:25.293|15552|I|qt5_supple| 516|* Qt version (runtime): 5.6.0
18:07:25.293|15552|I|qt5_supple| 517|* working path: "C:/tizen-studio/platforms/tizen-7.0/tv-samsung/emulator/bin"
18:07:25.293|15552|I|qt5_supple| 518|* binary path: "C:/tizen-studio/platforms/tizen-7.0/tv-samsung/emulator/bin"
18:07:25.293|15552|I|qt5_supple| 519|* Qt plugin library path: ("C:/tizen-studio/platforms/tizen-7.0/tv-samsung/emulator/bin")
18:07:25.293|15552|I|qt5_consol| 153|Display Type: QT5 Onscreen
ram_size 0x20000000
device fd:0000000000002d8c
18:07:25.299|15552|I|      main| 157|* Board name : Maru
18:07:25.299|15552|I|      main| 158|* Package Version:
18:07:25.299|15552|I|      main| 159|* Package Maintainer: Jingjing geng <jingjin.geng@samsung.com>
18:07:25.299|15552|I|      main| 160|* Git Head : 
18:07:25.299|15552|I|      main| 161|* 
18:07:25.300|15552|I|      main| 162|* User name : SKCro
18:07:25.300|15552|I|      main| 163|* Host name : SKCRO-PC
18:07:25.300|15552|I|      main| 166|* Build date : 2022-12-09 10:28:33 IST
18:07:25.300|15552|I|      main| 175|* Current time : 2023-06-13 18:07:25
18:07:25.300|15552|I|      main| 179|* Host Qt version : 5.6.0
18:07:25.300|15552|I|      main| 192|* Host SDL version : 2.0.4
18:07:25.300|15552|I|    osutil| 165|* Windows
18:07:25.300|15552|I|    osutil| 166|* LibPNG Version : 1.6.21
18:07:25.301|15552|I|    osutil| 173|* MajorVersion : 6, MinorVersion : 2, BuildNumber : 9200, PlatformId : 2, CSDVersion : 
18:07:25.301|15552|I|    osutil| 193|* Total Ram : 8346740 kB, Free: 1797596 kB
18:07:25.301|15552|I|net_helper| 178|Emulator base port is 26100.
18:07:25.301|15552|I|net_helper| 715|start sdb noti server thread.
18:07:25.301|15552|I|net_helper| 740|success to bind port[] for sdb noti server in host 
18:07:25.302|15552|I|      main| 239|kernel commandline : vm_name=BeanTV video=LVDS-1:1920x1080-32@60 dpi=72 clocksource=hpet consoleblank=0  host_ip= console=ttyS0 model=4ksero yagl=1 force_pat sdb_port=26100, vm_resolution=1920x1080
dsound: Registering endpoint notification callback succeeded.
dsound: (dsound_create_thread) Done
dsound: (dsound_initialization_thread) CoInitializeEx succeeded
dsound: (dsound_audio_in_init) success
dsound: (dsound_audio_init) finished
18:07:25.548|15552|I|      vigs| 246|vigs_gl_backend_wgl_check_gl_version:246 - Using OpenGL 3.1+ core
18:07:25.621|15552|I|      vigs|2670|vigs_gl_backend_init:2670 - Current GL_VENDOR = ATI Technologies Inc.
18:07:25.621|15552|I|      vigs|2672|vigs_gl_backend_init:2672 - Current GL_RENDERER = AMD Radeon HD 5700 Series
18:07:25.621|15552|I|      vigs|2674|vigs_gl_backend_init:2674 - Current GL_VERSION = 3.2.13399 Core Profile Context 15.201.1151.1008
18:07:25.626|15552|I|      vigs| 536|vigs_device_init:536 - VIGS initialized
18:07:25.653|15552|I|      yagl|1114|[3412/15552] yagl_egl_wgl_init_ext:1114 - WGL extensions: WGL_ARB_extensions_string WGL_ARB_pixel_format WGL_ATI_pixel_format_float WGL_ARB_pixel_format_float WGL_ARB_multisample WGL_EXT_swap_control WGL_EXT_swap_control_tear WGL_ARB_pbuffer WGL_ARB_render_texture WGL_ARB_make_current_read WGL_EXT_extensions_string WGL_ARB_buffer_region WGL_EXT_framebuffer_sRGB WGL_ATI_render_texture_rectangle WGL_EXT_pixel_format_packed_float WGL_I3D_genlock WGL_NV_swap_group WGL_ARB_create_context WGL_AMD_gpu_association WGL_AMDX_gpu_association WGL_ARB_create_context_profile WGL_ARB_context_flush_control WGL_NV_DX_interop WGL_NV_DX_interop2 WGL_NV_float_buffer
18:07:25.944|15552|I|      yagl| 320|[3412/15552] yagl_egl_wgl_get_gl_version:320 - Skipping GL_ARB_ES3_compatibility check
18:07:25.961|15552|I|      yagl| 348|[3412/15552] yagl_egl_wgl_get_gl_version:348 - GL_ARB_ES3_compatibility not supported, using OpenGL 3.2
18:07:34.281|15552|I|      yagl| 690|[3412/15552] yagl_egl_wgl_config_enum:690 - WGL returned 120 configs, 120 are usable
18:07:34.320|15552|I|     tuner|1483|device initializing...
18:07:34.320|15552|I| tuner_dec|1967|device initialization.
18:07:34.320|15552|I| tuner_dec|1968|still image directory : C:\tizen-studio\platforms\tizen-7.0\tv-samsung\emulator-resources\images
18:07:34.320|15552|I| tuner_dec|1206|load C:\tizen-studio\platforms\tizen-7.0\tv-samsung\emulator-resources\images/DTV_1920x1080.yuv420p file
18:07:34.395| 2548|I|     tuner| 619|section thread starting...
18:07:34.395| 4416|I|     tuner| 700|tsdemux thread starting...
18:07:34.395|15552|I|     tuner|1414|tuner configurations: sys:ATSC country:USA playmode:still table:C:\tizen-studio-data\emulator\vms\BeanTV\tuner_default.cfg
18:07:34.396|15552|I|     tuner|1517|device initialized successfully
18:07:34.397|15552|I|     input| 267|virtio_touchscreen_device_realize: 10
18:07:34.398|15552|I|       esm| 125|virtio_esm_device_realize
18:07:34.398|15552|I|     input| 494|virtio_hwkey_device_realize
18:07:34.399|15552|I|      evdi| 232|initialize evdi device
18:07:34.399|15552|I|      pkgs|  78|ADDON PATH: C:\tizen-studio\platforms\tizen-7.0\tv-samsung\emulator\bin\..\..\..\tv-samsung\emulator-images\add-ons
18:07:34.399|15552|I|      pkgs| 176|Add-on Directory is empty. No package install is required.
18:07:34.400|15552|I|     motor| 169|initialize virtio-motor device
18:07:34.400|15552|I|     motor| 185|initialized motor type: (NULL)
18:07:34.400|15552|I|     input| 412|virtio_keyboard_device_realize
18:07:34.402|15552|I| ext_input| 748|[maru_extinput_initfn] external input device was initialized.
18:07:34.402|15552|I|emul_state| 390|VM name: BeanTV
18:07:34.402|15552|I|emul_state| 586|VM data path: C:\tizen-studio-data\emulator\vms\BeanTV
18:07:34.403|10380|I|       ecs| 906|ecs starts initializing.
18:07:34.403|10380|I|       ecs| 878|Listen fd is 11724
18:07:34.411|15552|W|          |   0|libpng warning: iCCP: known incorrect sRGB profile
18:07:34.456|15552|W|          |   0|libpng warning: iCCP: known incorrect sRGB profile
18:07:34.456|15552|W|          |   0|libpng warning: iCCP: cHRM chunk does not match sRGB
18:07:34.533|15552|W|          |   0|libpng warning: iCCP: known incorrect sRGB profile
18:07:34.535|15552|W|          |   0|libpng warning: iCCP: known incorrect sRGB profile
18:07:34.545|15552|W|          |   0|libpng warning: iCCP: known incorrect sRGB profile
18:07:34.548|15552|W|          |   0|libpng warning: iCCP: known incorrect sRGB profile
18:07:34.569|15552|I|       ecs| 143|rotation 0 degree with setting: 100,980665,100
18:07:34.569|15552|S|    sensor| 600|unavailable sensor type request.
18:07:34.682|15552|I|mainwindow| 350|show main window
*********ReSet hax_vcpu->emulation_state 
18:07:34.708|15552|I| ext_input|1033|extinput reset. 
18:07:34.708|15552|I| ext_input| 417|Closed
18:07:34.708|15552|I|     input| 430|virtio_keyboard_device_reset
18:07:34.717|15552|I|       ecs| 143|rotation 0 degree with setting: 100,980665,100
18:07:34.717|15552|S|    sensor| 600|unavailable sensor type request.
18:07:34.729|15552|I|   rotator|  57|rotator status: 0
18:07:34.729|15552|I|     input| 510|virtio_hwkey_device_reset
18:07:34.729|15552|I|     input| 283|virtio_touchscreen_device_reset
18:07:34.730|15552|I|      vigs| 574|vigs_device_reset:574 - VIGS reset
Trying to vcpu execute at eip:000000000100016c
Trying to vcpu execute at eip:000000000100016c
Trying to vcpu execute at eip:000000000100016c
Trying to vcpu execute at eip:000000000100016c
Wait for shutdown qemu...10
18:07:56.793|18192|I|      main| 114|Shutdown qemu !!!
dsound: (dsound_audio_fini)
dsound: (dsound_initialization_thread)thread exiting ...
dsound: (dsound_audio_fini)end uninitialize to free
18:07:56.853|10380|S|       ecs| 826|select error.
18:07:56.853|10380|I|       ecs| 353|### Good bye! ECS ###
18:07:56.853|10380|I|       ecs| 360|close listen_fd: 11724
18:07:56.853|15552|I|       ecs| 963|ecs is closing.
18:07:56.853|15552|I|net_helper| 704|shutdown sdb notification server.
18:07:56.853|15552|I|      main|  91|Exit emulator...
18:07:56.854|15552|I| backtrace| 230|Stack backtrace for tracing...
18:07:56.854|15552|I| backtrace| 231|This is not an error
18:07:57.004|15552|I| backtrace| 134|#0000 0x0000000000bf1842 in ???????? from C:\tizen-studio\platforms\tizen-7.0\tv-samsung\emulator\bin\emulator-x86_64.exe
18:07:57.004|15552|I| backtrace| 134|#0001 0x00007ffe8cbfa8cb in initterm_e from C:\Windows\System32\msvcrt.dll
18:07:57.004|15552|I| backtrace| 134|#0002 0x0000000000a114b5 in ???????? from C:\tizen-studio\platforms\tizen-7.0\tv-samsung\emulator\bin\emulator-x86_64.exe
18:07:57.004|15552|I| backtrace| 134|#0003 0x0000000000a114db in ???????? from C:\tizen-studio\platforms\tizen-7.0\tv-samsung\emulator\bin\emulator-x86_64.exe
18:07:57.004|15552|I| backtrace| 134|#0004 0x00007ffe8c5e7ac4 in BaseThreadInitThunk from C:\Windows\System32\KERNEL32.DLL
18:07:57.004|15552|I| backtrace| 134|#0005 0x00007ffe8deda351 in RtlUserThreadStart from C:\Windows\SYSTEM32\ntdll.dll

Disabling features like the CPU-VT and GPU under Hardware Support in the emulator properties results in error messages, with the former feature spitting out this error message:

CPU-VT error message. "Failed to launch emulator. Enable CPU-VT to run the emulator."

And the latter resulting in this error message:

The GPU error message. "-device maru-virtual-tuner,system=ATSC,country=USA,table=C:izen-studio-datamulatormseanTVuner_default.cfg,stillimg=C:izen-studiolatformsizen-7.0v-samsungmulator-resourcesmages,wsi=vigs_wsi: Initialization of device maru-tuner-decoder failed: Device initialization failed"

My PC specs are as follows:
Dell Studio XPS 8100
Intel Core i7-870 (yes, that’s a first-gen CPU)
ATI Radeon HD 5700 Series
8 GB, 1,333 MHz RAM
(yep, my PC sucks)

What can I do? There are no alternative VM images I can try (from what I can see).

Any help is appreciated.

It is the AMD ATI Radeon HD 5700 Series They are not supported. It is mentioned in the Tizen Studio requirements.

Samsung Developer Relations

1 Like

How do I force it not to use GPU acceleration then if it’s not supported? Turning it off just throws an error stating that it’s unable to initialize the virtual tuner or something. Can I launch the emulator without the virtual tuner? I won’t need it to test my app.
I also cannot remove the GPU as my CPU has no onboard graphics (for some reason…)


I know that some people that had issues have gotten the emulator to work. I do not know if this was the AMD issue or something else. I’d suggest you search in this topic for Emulator and maybe also in the Galaxy Watch for Tizen forum here. They also have the same issue with Tizen Studio emulator for the watch.

Have you tried the Smart TV Simulator?

Samsung Developer Relations

1 Like

I haven’t tried that yet, as I can’t find the option to launch it… why is something as simple as picking a device/platform (emu, simu, or real hw) to test an app on have to be so complicated?

EDIT: Found out how to launch the simulator, but it only lets me pick the wearable simulator (the TV simulator doesn’t do anything for some reason).

Are you using the simulator or the emulator? In the emulator you may have to click on the Create and create a TV there is only one TV option.

Samsung Developer Relations

The simulator. It’s this button that doesn’t do anything when clicked:
The button directly above it works (but launches the wearable simulator)
The top button attempts to launch the emulator (or sends the app to my TV if it’s connected) - I usually do testing on real hardware due to neither of the on-PC options working correctly.

Right now since I have Windows 11 I can’t even launch the Tizen Studio extensions like Device Manager or Device Emulator so I can’t personally help much.

Did you try the Tizen Developer Forum for web applications ? there may be some useful information there.

The Requirements for the Emulator are HERE I just know from Watch Development that the AMD card will now work.

Information on Tizen.org on running on Emulator and Simulator are HERE

Details from the Smart TV portal for simulator is HERE
and the Emulator below that

I hope you find a good answer this comes up way to often.

Samsung Developer Relations

1 Like