Error to initiate Tizen Emulator

Hi community.

I need a little help to start the Tizen Emulator to SmartWatch and TV.

I use Windows 10 and Visual Studio 2019 with the extension of Tizen.

When i start the emulator, it shows a error message:

“Decompressing Linux… Parsing ELF… No relocation needed… done.
Booting the kernel.”

And nothing happens after that.

I already researched this error and found no topic about it.

Does somebody know what i have to do?

Thanks a lot.

Regards,
Bruno Tragl
brunoatragl@gmail.com
brunotragl@outlook.com

This happens a lot.

To launch Device Manager you need JAVA_HOME set to
C:\Program Files\Java\JREx.xx.xx
To Launch the Emulator Manager you need the path to include
C:\Program Files\Java\JREx.xx.xx\bin

If you update Java be sure to update the paths in your environmental variables as the update doesn’t do that.

Ron
Samsung Developer Program

Hi Ron,

Thanks for your answer.

I installed the JDK 8 and the version of JRE is 1.8.0_251.

I really forgot to create the enviroment variable JAVA_HOME, before Tizen extension, i hadn’t installed JDK on my pc.

But i didn’t understand where i should to put the path on Emulator Manager, like you say.

I tried to do a test and still it show the error message.

Sorry, i new in this.

Thanks a lot.

Regards,
Bruno Tragl
brunoatragl@gmail.com
brunotragl@outlook.com

Hi, Ron.

I researched the Java configuration and understood its point.

I created the JAVA_HOME system variable and updated the Path variable.

But I still have the problem.

Would you or anyone, have other information regarding this error?

Thanks a lot.

Regards,
Bruno Tragl
brunoatragl@gmail.com
brunotragl@outlook.com

This is the error, when i start the SmartWatch emulator

And this is the error, when i start the SmartPhone emulator, the same error

Since Emulator Manager is working the paths are all OK

For the Watch.
I used to get stuck with an emulator at that process when I didn’t close the watch emulator properly and basically I restarted my entire system to clear all caches. But I don’t think that is your problem. But try it.

If it still hangs open emulator manager select the wearable Circle click on edit
Select HW Support GPU VT should be on GPU should be off click on Launch and it should load a default watch.

I don’t know of anyone that does Tizen Mobile, I don’t even understand why they have it in Tizen Studio.

For the Smart TV I can’t launch it in my work environment due to firewalls. What error do you get on that.

Edit: on my personal computer the setting for the Smart TV Emulator is GPU VT on and GPU on

Once you have the emulators working let us know.

Ron
Samsung Developer Program

Hi Ron,

Thanks for your response.

I used the SmartPhone emulator just to read the error message, because the error message on the Watch emulator doesn’t show all the text.

I changed the options, like your instructions, but unfortunately the error continues to occur.

Here are my clock emulator settings:





Thanks for your help.

Regards,
Bruno Tragl
brunoatragl@gmail.com
brunotragl@outlook.com

In the HW Support turn CPU VT ON and leave GPU off. If it still won’t launch Turn them both on.

Let us know if either one of those settings has an effect.

Ron
Samsung Developer Program

I’m having the same problem and changing these options doesn’t help. Besides is it not better to have it on for better performance? It should be working.

Can this be picked up by Samsung? The way I understand it, it is not possible to debug and test applications for Tizen on Windows anymore.

Hi Ron,

I don’t know why, but i can’t apply the option CPU VT.

When this option is enabled, the “OK” button is disabled.

See:

Thanks for help.

Regards,
de Bruno Tragl
brunoatragl@gmail.com
brunotragl@outlook.com

I don’t know where you heard that from, I’ve never seen any reports about this. Are you running a HiDef monitor? I’ll see if I can find any other solutions.

Ron
Samsung Developer Program

Ahh I forgot, If you have an AMD card there are issues. You probably need to contact tech support with a request to see if they can help with that.

Ron
Samsung Developer Program

No, i’m using NVIDIA card…

This is my computer configuration:

  • AMD FX-8300 3.6
  • NVIDIA 8600GT 512
  • 8Gb RAM

Thanks.

Regards,
Bruno Tragl
brunoatragl@gmail.com
brunotragl@outlook.com

NVIDIA GTX 1060 6GB
Intel i7-2600K
16GB RAM

Looks like the emulator doesn’t work for AMD processors

Altough. I have an Intel processor with vitualization turned on, Hyper-V disabled and it still doesn’t work for me either. The newest HAXM (7.6.1) conmplains that VT-x is not supported on my processor and won’t install. Interestingly 7.0.0 installs fine, but apparently won’t run the emulator anymore.

Really it is such a battle to get it to work. It is also annoying that I’m forced to choose between running Tizen emulator and Docker desktop. because of the Hyper-V.

Now I’m starting to understand why Tizen apps are so scarce.

I finally got it to work.
I installed HAXM 7.6.1 from here: https://github.com/intel/haxm/releases
The key was to run silent_install.bat, not intelhaxm-android.exe.
The CPU boost option then got active for me.
I enabled both CPU & GPU HW Support and it worked.
Again, that was on Intel processor. Don’t think you can run it on AMD.

2 Likes

you can check here nvidia system monitor