Error upload on gear s3 frontier

Hello everybody first sorry for my english i am from belgium and i speak normaly french.
After install the new version of galaxy watch studio . I cant upload face on my watch.
I have the same message for all my faces.

Somebody have the same problem ? I dont want to upload on the store its only for my personnal use.

Most likely your Watch OS was updated to Tizen 4 and you need a new Developer Certificate for that new OS.

See How To Get a Certificate

There could be other issues that create this error message but this is the most common with Galaxy Watch Studio (Designer).

Samsung Developer Program

I have the same error every time i try to load a watchface to my Gear S3. I tried to generate a new distribute certificate in the Galaxy Watch Studio at Project->Distribute Certificate, it worked but didn’t change anything, still the same error. Do you know what i could try?

(Sorry for this bad English, i’m from Germany :slight_smile:)

Did you reboot your computer after creating the new distributor certificate. The old one stays cached.

Reboot the Watch by holding down the home key until it says rebooting This will force an RSA Encryption key acknowledgement when you first connect to GWS so watch for it. If you don’t agree it won’t install.

If that isn’t it Let us know the exact error message.

Samsung Developer Program

I rebooted my computer after creating the new certificate but still the same error. I also rebooted the watch, but there was no RSA Encryption key acknowledgement.
That’s the exact error message:

Hello everybody the problem is closei have create new certificaye for me and my watch.
You can close this topic

If you reboot the watch by holding down the home key until it says rebooting it has to show an RSA Encryption Key Acknowledgement when you first try to run on device. However, the FAQ 23 does suggest you wait a full minute after rebooting before you attempt to reconnect to your watch.

The FAQ is more detailed than I can post here.

The only other possible things I can think of is your watch and computer are set to different times, or you never updated to Tizen 4.

Samsung Developer Program