Faces GWS install to watch

Hello I have a big problem transferring the dial from GWS to my watch. everything is up to date, (java etc) watch and phone are debugged I cannot in bt (tizen 5.5.0.1) I rebooted, reset, made the certificates tried all the solutions found on the internet I think it is a because of the RSA key, how to solve this problem which lasts for 2 weeks? If anyone has an idea that works, I’m interested in it.
thank you all good day and really thank you to the one who will have the answer

You cannot do SDBoverBT with Tizen 5.5 you have to do it by WiFi. The Tizen OS team is aware of this and say it is an update but I’ve not seen this update.

To connect see FAQ 23 it has a pretty intensive process.

If you are on Mac Catalina you will need to download Tizen Studio and use the SDB from that. I can provide you for more information on how to do that.

If all else fails download Tizen Studio and You’ll need the device manager. Connect by Wifi from that and it will force the RSA encryption key and then you can use GWS. Do not attempt to install the full Tizen Studio as that takes hours.

If you get stuck at some point. I think I know all the solutions but here are the check points
Can you connect to device to get Distributor Certificate
Can you connect to device to install App (RSA Encryption Key)
Can you start to sideload the watch but it stops at some point

Ron
Samsung Developer Program

I am under windows 10 it is blocked at the “connected watch” level with the correct number it is running but it cannot find the watch and the upload window does not appear. certificates are ok,

“Can you connect to the device to install the application (RSA encryption key)” I do how and which application is it?

And I want the necessary information for “Tizen” what to download and the procedure to perform, thank you for the follow-up

Reboot by Holding down the power key for Active2 or (Power and home key together) for Watch 3 until it says rebooting about 15 seconds.
Restart your computer (don’t just turn off and on but use restart to clear any caches).

After phone launches make sure WiFi is always on and give it a full minute to secure all connections.

Launch GWS but don’t connect yet

Put your watch at a preinstalled watch face and keep it active

Try to run on device and keep an eye on your watch. a RSA Encryption key will be sent and you need to accept this You do not need to click on the do not show again but you do need to accept it.

Then the watch face should sideload (transfer) to your watch.

If that fails after you accepted the encryption key then when you did the latest Tizen update it removed the Developers Certificate an you need to create one.

If the RSA Encryption key acknowledgement does not appear…

go to your C:/USER/USERNAME/ folder
there is a hidden folder .tizen
in that is SDB and SDB.pub files move them or rename those

Restart computer and watch and try again That is 99% sure to force the acceptance if it doesn’t then I’ll tell you how to do it with Tizen Studio. It isn’t difficult but it takes a lot of time.

Ron
Samsung Developer Relations

J’ai tout essayé …La clé de chiffrement n’est jamais apparue donc je suis bloqué à ce niveau si vous pouvez m’informer la façon sur Tisen je veux bien tester je n’est pas beaucoup d’autre solution…merci pour moi et les autres

Before going to Tizen Studio route do the check list one more time
On Watch
Developer options are enabled (tap on software version 5 times in about watch settings)
Debugging is turned on in about watch settings
Connections WiFi is always on or when on Auto Bluetooth is off

on your PC
Be sure the Ethernet is unplugged or disabled and you are connected via WiFi
the channel you are connected to is the same 2.4 Ghz channel as the watch is.

Launch GWS and select run on device and enter the IP Address for your watch
In the build menu select create Developer Certificate (do not create a new Author Certificate)

If you can’t do this then you need to restart everything try again often it is something being cached somewhere

Try using your phone as the wifi hub for both watch and computer.

Instructions for Tizen Studio to follow

Ron

I tried everything… The encryption key never appeared so I am stuck at this level if you can inform me the way on Tisen I want to test I is not much other solution… thanks for me And the others

It may just be you already accepted it but not likely be sure debugging and developer options are enabled.
Go to this page and download Tizen Studio and then go to this page to see how to install

IMPORTANT You do not need to open Tizen Studio but open Package Manager and go to Extension SDKs and be install Samsung Certificate Extension and Samsung Wearable Extension (you will need to accept the terms to install)
Click on the configuration settings (gear icon) and make sure the Certificate extension and wearable extenstion are enabled.

In Windows finder expand Tizen Studio and launch device manager give it at least 5 minutes to fully connect to the network.

Click the Add (large + icon) and give your watch a name and enter the IP address. Watch your watch it will load the RSA Encryption key to accept but may take a few seconds but be vigilant.

If Device manager gives an error message saying it cannot connect, restart watch and device manager.

for others
On macOS Catalina the sdb that comes with GWS is incorrect replace it with the Tizen Studo’s SDB.

When you have downloaded tizen studio,
1- Open finder> user> (username)> tizen-studio> tools> (you will see the sdb file of tizen studio)
2- Then open a new finder window> applications> right click on galaxy watch studio> click where it says (shows package contents)> Contents> tizen> tools> (you will see the galaxy watch studio sdb file)
3- Replace the galaxy watch studio sdb file with the tizen studio sdb file.
4- Restart the mac and try to connect the smart watch

Ron
Samsung Developer Program