2.0.1 will not connect to GW3

I have turned on debugging on phone and watch
I have tried BT and WiFi.
Tried Wifi with out my Note20 5G phone.
I can see the watch IP address on my router.
Studio just will not connect so I can send a watch face over.

Make sure Wi-Fi is set for always on or BT is turned off.
Keep a close look on your watch, a pop up will be shown to accept the RSA key and you have to accept it very quickly. If you don’t see the RSA key pop up, reboot your watch by holding the home key button pressed for about 15 seconds or until it says rebooting.

In addition to what JSJ said.

In your watch settings connection tap on the connection and note the IP address
Enter that into your GWS run on device box using the + icon.
If you are like me with a personal account my IP address is not in the GWS Search zone (the number is too low) so it is never found.

Be sure to generate your Author and Distributor Certificates before trying to sideload on the device.

Samsung Developer Relations