Font problem

I use a font (“digital”) on text appearance. I save my project, close WFS. But when i open WFS, with my projet, even if i see my font on text appearance, it is not the one i use. It is no more digital but it is the name of my font (difi.ttf) in selection . How come ? what is wrong?
image

The last I knew you have to install the fonts in order to use them. Simply adding them to WFS project does not work.

I can’t find my notes about this I can verify this if you tell me how you are adding them to your project.

Ron
Samsung Developer Relations

I download free font to a directory in “my documents”. then i add it i WFS in text appearance . Then after, for other purpose i install it in win10. Buy the way, i cannot delete it in WFS.

Try moving it to the same workspace that your project is located.

I tried Workspace\Resources with font.ttf located there and it worked for a Beta version but I didn’t try it for anything after that. I added the Font after moving them but that may not be necessary.

If that doesn’t work, I’ll see if I can get better instructions.
Sorry this is a Holiday week in the US so I’m not working a lot or hours this week. Otherwise I’d be more helpful.

Ron
Samsung

1 Like

I put it in my workspace, and just in case, i install the new font in wondows too. Close WFS and reopen it and seems to be fine. But i cannot delete the unwanted font in that face.

Thanks! Hope you going to have a good Holiday.

I remember now I couldn’t remove the bad font either.

If you want to experiment make a copy of your project . Rename the file to .zip and open it. Remove the bad font from the resources folder.
Zip it back up
rename it back to wfs
and see if that removes it. It worked with GWS but I never tried it with WFS.

Ron
Samsung Developer Relations

no, it does not work. It says invalid file. Nevermind, it is only in this face, i live with it. Maybe in a future update, there will be an option to delete font.

Thanks for your help

Hi Tremal,

Thanks for letting me know. I’ll try to keep this in mind if anyone reports a similar problem. And I’ll report not being able to delete the font is a bug.

Ron
Samsung Developer Relations.

Added fonts cannot be deleted and i mentioned it elsewhere this problem

Please see screenshot as well about font folder auto deleted and creating build fail in 1.0.12

Store the font used in the resources folder of Watch Face Studio

I did that it didnot work. I added the same fonts again and selected for each text that worked for me.

Hi Osman,
First they have to be TTF not OTF and I’m pretty sure fonts designed with a Mac will not work on Windows.
You have to install the fonts into Windows / Mac
Put the fonts or an alias to them in a folder in the Workspace folder where the project resides and select the fonts from that folder.

This process worked for me twice and before I did it that way I got the font file does not exist.

I got it the error one time in one project after doing the install etc. but I had a text file that used the old version still and had to remove the text add it back in and change the font to the new font.

Ron
Samsung Developer Relations

Hi, i have been using TTF fonts but they were not stored seperateĺy in workspace folder.

I will try this to copy the needed fonts in workspace and then add them , çompile and generste build and then see if the Label blank issue works

Yes by adding the font again to text layers fixed no font file font on such wfs projects.

Thanks