TTF font not working in V1.4.20 (with spaces/dots in windows username)

Today I have upgraded WFS from V1.3.13 to V1.4.20.

When I open an old watchface it’s converted. Once opened my custom TTF font’s are not working anymore.
Also when I create a new project the specific TTF font doesn’t work.

Some other TTF fonts still work.

As soon as I downgrade back to V1.3.13 and load the unmodified project the fonts work again.

Hi. What do you mean by ‘not working’ ?
They’re not showing at all or are cropped?

What do you mean by custom ttf? Bitmap fonts (images uploaded to WFS) or own ttf fonts?


When I select add-font in a textbox for example the text is not rendered in the chosen font.
I use a TTF font (not as bitmaps), the same as I used in WFS V1.3.13, where it works without problems.

It is this font which works in V1.3.13 but not in V1.4.20:
Avantgarde Font

You have to both install the fonts in the Windows (Or Mac) System as well as have them in the path that WFS can find them.

If you had them in the folder where WFS was installed they would have been deleted by the installer. I put mine in Workspace/Fonts folder and they are working.

Samsung Developer Relations

1 Like

I did a lot of testing today. Can’t seem to get it to work on my Windows 10 development machine with V1.4.20. Still works fine with V1.3.13.

But I had a clean install of Windows 10 (older version) in a VirtualBox. There it works even without installing the fonts in Windows.

So it now seems somthing in my Windows installation… but no time to reinstall Windows… work to do :frowning:

I did some more extensive testing and I found the problem. My windows user is called “M.J. van der Zwet”, the user folder is also called this. So with spaces and dots in it.

It seems the latest version of WFS can’t handle this. Even if my working folder is on another drive.
I installed WFS on my VirtualBox under user “Test” and it worked flawlessly… then I created user “M.J. van der Zwet” and logged in. Opened WFS added a Text item changed the font and it failed.

So if the username contains spaces and/or dots WFS fails to load the fonts.

1 Like

I have a dot in my username and it worked for me, Your font worked as well. I didn’t try to run on device but it worked in the preview window. WFS 1.4.20

Maybe it is the space or a combination of the two.

Samsung Developer Relations

It’s the combination, maybe only the spaces… haven’t tried it with only spaces.

But I think it’s the spaces.