Galaxy Watch 4 bricked

Hi,

This is probably unrelated to WFS and it’s probably the wrong forum but I just wanted to see whether anyone else has has this issue…

A couple of days ago, whilst developing a new watch face using WFS, I downloaded a test version to my GW4 Classic via the WFS/adb/wifi (standard practice).

I noticed after the download that the measure-heartrate button on the test watch screen wasn’t working, so I decided to restart the watch. I shut it down using the pull-down menu on the watch screen and now it will not start up. It’s basically a brick.

I’ve tried all the methods I can find on the internet for fixing this sort of issue, but it won’t start, won’t reboot, won’t charge (it had plenty of charge when I shut it down).

Perhaps it’s a problem with my watch (I’m sending it in for repair), but there’s also an outside chance that the issue could be connected to loading watch faces using WFS / adb.

Cheers,

Rob

Hi Rob,

Try holding down both buttons at the same time for over 15 seconds and see if it reboots that way. I have no other guesses. It is possible it was adb but I haven’t seen any other people reporting issues. My guess is that the heart rate wasn’t working because there was already an issue with the sensors or something.

Ron

Yeah, thanks Ron. Done all of that stuff multiple times in the hope that it will wake up, but no joy.

There was no warning of problems before it died. It was working normally, then there was the heart rate thing and then dead. I suppose I could say it suffered a heart attack! :dizzy_face:

Anyway, it’s being sent for repair tomorrow.

Hi Rob,

Yes, this happened to me. I woke up one morning with a blank screen and could not boot the watch using any method of note, including the two button Klingon death grip.

I managed to get a slot at a Samsung repair shop - which is another story entirely - but after two and a bit weeks, in the post this morning arrived what appeared to be a new watch (albeit with the same serial). I say this as the casing was pristine with factory stickers.

Interestingly, up until the latest firmware update, something in the previous one seemed to be draining the battery to the point where the watch would not last a day. The software that suspiciously looks like it’s doing the bricking had actually fixed this problem and the watch was running well.

I’ve seen several reports of this regarding the last Galaxy Watch4 software update. If anyone else experiences it they should have it repaired by Samsung.

It doesn’t seem to affect Galaxy Watch5 versions.

Ron
Samsung Developer Relations

Thanks Ron and Dataylor01. Good to know that I’m not the only one. My watch is with the authorised Samsung repairer now. I’ll post an update when I get it back.

it’s shameful, i upgraded my samsung watch 4 classic this morning and it broke.
samsung should replace it at home

I agree it is bad be sure to contact support for a replacement. Also post this to the product support community. Samsung really does care about what people think about their products.

I would recommend you use the Samsung Members App for feedback
or
go to https://www.samsung.com and depending on your location
either → Click on Explore Tab → Click on Community
or
Scroll all the way down to the bottom of the page and under support is a link to the community

Ron
Samsung Developer Community

I did as you suggested but I don’t think it helps, I’ll keep you updated

The community won’t help but it will get Samsung’s attention. Although I think they know it already.

You need to contact product support. One person that did that said he had what appeared to be a brand watch but with the old serial number within a week.

Ron
Samsung Developer Relations

Quite a few people are having this problem – GW4 bricks on restart.
There is a huge discussion on Reddit (see https://www.reddit.com/r/GalaxyWatch/ and search for: brick)
Yes, I agree Samsung should fix this free and, in fact, some out of warranty customers got free repairs.

I returned my watch through the retailer I purchased it from (it’s still covered by Samsung warranty). I’ve been waiting for almost 4 weeks now and still no sign of it. I’m not happy. I’ll also raise this as you advise Ron.
Rob

Today my Watch 4 returned from warranty repair. The specification says that the motherboard, battery and back cover have been replaced. The watch was bricked by Samsung software.