I do not want to Brick my watch

I made some changes . I took the One UI5 update on my GW4 Classic . I noticed like others that the HR LED sensor Was stuck on a lot . I thought it was a Problem generated by Facer . With loading a native Face and swapping back then rebooting I managed to get it to work properly for a short while .
So I decided to do a fresh install on my watch and just try WOS4 and UI5 on their own . So the HR LED is still stuck on . Well the simple answer is not to use it . and rely on what Samsung Offers . I know it will be sorted eventually because the HR is important to people but having a Really bright Flashing LED on all the time is going to suck the Cell Dry .
I discovered how to get o the " Bios Settings " . Going for a reboot with the two Physical Buttons then morse on the upper one when the Rebooting Message comes up .
I tried a couple of things on the Longer list but could not get a NEW WATCH install . there was a lot of evidence that the Memory was not completely cleared . Like the WiFi Connection Survived .
I wonder if you more experienced Guys can please point me at the correct one to get a Clean Install from without BRICKING my watch .
BTW I have now loaded WFS 1.5.7 i am finding it Brilliant I have opened some of my 1.3.13 stuff with no problems so far .



What is a hr led light sensor? :thinking:

You mean the green flashing light under the watch face?

1 Like

Yeah .The green light that warms your wrist up . The SP02 light is red sor the two give yellow . Nice little light show . I do not use SP02 . The readings ar Scary and the light on all night sucks the Battery . Just when I think I have it behaving it goes wrong . I think it is a Bub between WFS and Facer . I am not clever enough to write something to test with Android Studio .

Could it be due to taking reading countinous…e.g sleep tracking…, hr monitoring?

When not wearing no led

I tried other watch faces (i.e default) …also active led blinking btw

1 Like

On Facer it used to be if you Palmed the display the Sensor switched off . That stopped working and I uninstalled Facer but the problem still exists on WOS4 . I have tried all the settings for The Samsung Health . Ie Constant , 10 Minutes and Manual HR Readings . All with the same result . Before getting Ron Involved I wondered what the experience of others was . My main interest with the Topic was to find a way of doing a clean Install from the Advanced settings rather than Bricking my Watch .

I wonder if its due to the update(os) not the watch faces

1 Like

Yes. Thanks for staying with this . Interesting lots of views on this Topic but not many joining in . Often it is not those who have the answer that make a good Topic but those who have similar questions . Sorry to keep bringing it up but Facer has been problematic with Steps and now HR . So I thought with UI5 installed that was the problem . But getting rid of Facer did not solve the Issue of the HR sensor . I am using a WFS 1.5.7 Face I made with no HR at the moment and it seems to stay off at the moment . I have set Galaxy wearable to check the HR every 10 minutes . Other settings seem to keep it on .

Try removing all wfs, watch facers too. And maybe samaung health. See if that help.

Are u able to reinstall the clean? Thought a factory reset will do?

If you have removed the ui 5 already. I not sure how to reinstalled…

Maybe try a factory reset and try the installation step again?

1 Like

Yeah .that was the Kick off of the Topic . I did a factory reset from the Bios or whatever it is called . With a memory wipe and declined the restoration of my backup but I noticed there were a few things still hanging about . Notably the IP address of my WiFi . I am pretty sure that once you have installed something like One UI 5 you can not Roll Back .
If you know how to initiate a Full Clean install I would be very Greatfull . I know it is one of those choices in the lists I have shown above .

Hi what was the error? By the way is your watch working now or blank as in no os?

Its scary to think after upgrade u cannot factory reset. Probably need to ask samsung support. If the only think u tried so far is factory reset and watch is still under warranty?

1 Like

Btw check out https://forum.xda-developers.com/
This forum. There are more experienced developers there they cover more topics and tools

The Error that bugs me most is . The HR Sensor stuck on . If the HR reading is called for by WFS it gets stuck on . Sometimes not even flashing . Consequently useing a lot of power and warming the wrist unessicarily .
The watch has no Manufacturers Warranty as I bought it as a Second User . There is nothing wrong with the Watch . it works perfectly . it is a Software problem for sure .

So not yet brick? I asking about when doing factory reset what happens?

Oic what u mean…after factory reset in wasnt fully clean. Partial stuff still in memory

1 Like

Yup that is what I mean .

I realised could some of those settings come from the wear os app on your phone? Data from phone synced to your watch?

1 Like

Samsung Watch and Samsung Phone , I bet they do a lot of chatting about all sorts , especialy Health Related Stuff .

So i think you can try uninstall wear os and wearables from your phone. Then do factory reset on watch

1 Like

Same here unable to find a way to turn off led…unless not wearing the watch. But my is a gw5 strap well into my hand so no led light leaking.so doesnt bother my eyes… but bother the batteries of the watch.

+to safe battery i dont wear it when at home

I still think it samsung health doing the led flashing. Sleep tracking - uses hearth rate to check (no way to turn off)

Stress - (uses hearthrate also) (dk now can turn off a not)

Exercises auto record (uses heartrate also)

Sinces these are auto…i assume its always reading your heartrate and movement.

So only way to solve it or test. Is to remove samsung health from both phone and watch

1 Like

Ok Thanks Good Idea . I would still like to do a clean install on my Watch . I am a little surprised that Ron @r.liechty_SDP has not chipped in on this one .

Hi, i guess its beyong the scope of wfs if its a firmware issue.

That why his quiet.

1 Like