Galaxy Watch Designer(GWD)

I have no idea why why my GW 46MM doesn’t connect to GWD. i tried wifi connection by putting same IP address on GWD. Still not showing connection. what should i do. i turn debugging on still doesn’t work. Stupid GWD app waste my time.

New privacy laws require that an RSA encryption key be accepted before data can be transferred. This does not last very long and the logic will assume that it is an attempted hack and assume not accepting is the same as No.

Turn on Debugging, In the About watch settings go to software version and tap on that 5 times to turn on developer Options.
hold down the home key until it says rebooting. this resets the RSA Key encryption

Restart your computer,
Restart your mobile phone (should not be necessary but why not)
Open GWD put the IP address of your watch in the search and connect to device
Watch your watch carefully and an RSA Key acknowledgement should pop up select OK You won’t have to do it again.

It should connect just fine after that. If it doesn’t
You may be on a different network or have your computer using an Ethernet connection instead of wireless connection to the network those used to be the frequent problems but almost always it is the RSA Key acknowledgment now.

Hope this helps

If not see this comprehensive instructions

Samsung Developer Program