New issues connecting Galaxy Watch to GWD

Hello Ron,
your manual worked perfectly.
But now after upgrading Win7 to Win10 i have the same problems connecting my watch to GWD.
GWD finds my smartphone, but not the watch connected via sdoverbt.

Is there anything different at Win10?

Thank you,

Anmerkung 2020-03-27 142749

Hey @sas1585493544 , first make sure your watch is connected to your phone through SDBoverBT. If it is not connected and facing problem to connect it, reboot your watch and try again. I hope it will help. It worked in my case.


Hello Azad,

unfortunately not.
The watch is connected to the phone via sdoverbt. Watch reboot without result.


You may try the following steps,

  1. Make sure the developer option and debugging mode are enabled on both the phone and watch.
  2. Close GWD and restart your computer.
  3. Hold down the home key button on your watch until it says Rebooting… (hold about 15s).
  4. Be careful to acknowledge the RSA Encryption key and if you don’t do it quickly, it goes away and never ask again.
    Now, try again and if you don’t have the distributor certificate, generate it.


Hello Azad,

thank you for your reply.
I worked a lot with GWD in the past and had no problems to connect my watch
I followed all the steps from Ron´s manual, mentioned above.
I just have the problems since upgrading to win10.
But i will try your suggestions and report it.

Thank you

I appreciate it. It would be great to extend my knowledge about GWD. Still if I can find anything specifically related to your problem I will let you know. I hope the problem will be resolved quickly.


I did a recent Update to Windows 10 and had to re-acknowledge the RSA Key on my phone and not just the watch. But you would need to acknowledge the RSA key on the device again after the update to Windows 10.

So restart everything (Don’t just shut down and start but use restart
Restart Computer
Shut down and restart phone
hold down home key on watch until it says restarting.
Phone settings - Developer options - Enable USB Debugging
Launch SDBoverBT on phone
Connect USB cable to computer
Connect USB Cable to phone
allow data access to phone
If a message on SDBoverBT comes up about an RSA key allow it always check computer too for any messages
Select Watch to connect to in USBoverBT
watch the watch carefully and RSA Encryption Key acknowloedgment will come up you need to allow that

If the watch shows in the run on device window you should be good to go if it fails to load then create a new distributor certificate.

Samsung Developer Program

Hello Ron,

nice to hear from you :slight_smile:
I followed your instructions. But there shows no RSA Key message up…?
Also i can´t find a USBoverBT option.
What am i doing wrong? Sorry!
Shouldn´t i also activate developer mode and usb debugging on the watch before restarting?

Thank you,
best regards

Should I also activate developer mode and usb debugging on the watch before restarting?
Yes to both , then try reconnecting and look for the RSA encryption code, acknowledge it
and it should work

USBoverBT now that is a silly typo
Open SDBoverBT and from there tap on Select Device for Debugging if it doesn’t show the device already. Then click on the device you want to debug. If you rebooted your device not just turned it on and off it will show the RSA Encryption Key acknowledgement at that time.

Some people have told me they restart the watch after turning on Debugging and Developer Mode I think it just has to be on before you try to connect to SDBoverBT

Samsung Developer Program

I just had the same thing happen tonight.

I spent the day developing a watchface to install on my Active 2 watch, made sure all the debugging permissions, etc. were set properly and it refuses to Scan & connect with my watch via the Galaxy Watch Designer interface. When I test run my watchface in that software it shows a simulation of how I’d want the watch to look and run. But can’t get the needed handshaking b/wn the GWD, my Galaxy S10+ phone, my Win 10 PC and my Active 2 watch.

I’ve done all the watch and software re-starting too. And hit all the “Accept” messages (incl. the Ack for the RSA) that appeared on PC in GWD and on phone/watch as they appeared. We’re totally puzzled at this point. I’m not a programmer, but someone here with a EE background is…

If you got the RSA Encryption Key you did connect.
What you didn’t say you did but maybe you did do.
You need the Author Certificate and the Samsung Distributor Certificate. If you had a distributor certificate from another watch you can build the project just fine but it won’t load except on that particular watch.

The only other reason I’ve seen that a watch that connects is a problem with AOD you can by-pass that by turning on developer options but I don’t recommend it even if you have AOD turned off on your device.

Samsung Developer Program


you’ve been a big help today but i am still unable to connect to my new Galaxy watch. I’ve followed every instruction on how to connect with no success. I’ve tried wifi (setting up my PC on the same wifi network as the watch) and bluetooth thru sdboverbt. i never got the key you mentioned. i’ve turned off debug on everything restarted and turned it all on - still with no luck. with sdboverbt i get my phone showing up in the connected watch but it doesn’t do anything. I did have an older frontier gear 3 that worked before - could that be the problem?

Remember you will need a new Distributor Certificate for your Galaxy Watch after you connect.

For the SDBoverBT you need to enable USB Debugging on your phone but lets just try the WiFi connection for now.

Make sure Debugging is on. go to the About watch Software version and tap on it 5 times to turn on Developer Options

If you ignore the RSA encryption key acknowledgment one time it takes that as a no and never asks again.

Hold down the home key on your watch until it says rebooting
While it is rebooting restart windows and your watch although that might not be needed.
Launch GWD and connect to your watch.
Make sure your IP address is in the dialog box as before…
Once it starts to connect watch the watch very carefully, The RSA acknowledgement only shows for a short period of time. After that you should be good to go.

Samsung Developer Program

Thanks for the info. I’ve tried all of this and more. I’ve rebooted everything, turned off and on debugging, placed my PC in wireless mode so it’s on the exact same router as the watch (and turned off wired). I’ve even tried to upload my design to Samsung so I could just download it but that won’t work because it keeps telling me that the cert is used by an OLD watch face I put up there years ago. I’ve even run the new Author cert wizard. When i try the SDBoverBT, my watch comes up on Watch Designer but when I click on it, nothing happens. Phone is in debug, watch is in debug, SDB connects.

I love this app but have had so many issues with it trying to connect to my watch that I’ve all but given up and moved to Facer


Hi Joe,

Yes, Distributor certificates are specific to a watch and you need to create a new Distributor Certificate for each watches GUID. Once connected just create a new Distributor Certificate.

Author Certificates tell the seller store who you are so if there is an issue they can track you. The distributor certificate for developers tells a watch that it is OK to install on the watch.

Distributor certificates are replaced by Samsung’s when you upload to the store.

Samsung Developer Program

Well, I guess that persistence is key. After retrying to connect so many times, my watch finally connected. It asked me to get a new dist cert, which I did. Then I tried to upload my design and GWD came back with a warning, saying that Author cert not match

Hi Joe
Try your old author certificate password
it should work

Thanks Malcolm. Unfortunately, i do not know where to get it. Once i finally connected to my new watch, i ended up renaming the old cert’s (author and distributor) and creating new ones. I’ve done this a few times now. When i originally got 1.8 GWD working, it gave me the same errors.