GWS BUG: Opacity not working for additionaly added Fonts

Hello, i don’t know if this is the right place to post bugs for GWS, but i couldn’t find a better location, it was this or improvements :smiley:

So to get to the point, what i just found out, is that opacity is not working on additional imported fonts, just the standard ones in GWS, i tried many custom fonts, but for none the opacity can be changed, directly or via expressions.

Have a great Day

I guess this is as good a place as any. Are these true type fonts? I couldn’t duplicate this with what little resources I have. Perhaps someone else can.

Samsung Developer Program

Thanks for your quick reply, as always Ron.
Yes, true type-, not bitmap fonts, some additional free ones imported into GWS,
I will check this in a fresh/new watch face, not one that is already created for 2 weeks now, and i keep updating it.

Later Edit:
Tried it with a completely new watch face, but without success.
Seems this is only happening with the last 4 .ttf font files i downloaded, it works for older used .ttf files, all .ttf files have the .ttf extension and not the .TTF
Anyone has any ideas what I should try to solve this, or at least pin it down?

I once had similar problem (there was no GWS back then). It somehow corrected after I restarted my PC. Now I tried it again, but in GWS the added fonts do not respect opacity settings no matter what I do.

Hi @Razaa-Watch-Faces,
I have checked and found the same issue that the opacity doesn’t work with the imported true type fonts in the Run Preview of GWS but interestingly it works fine on a real device. Did you check it on your watch? I hope it will work fine on your watch too. Just check it and let us know.


Thank you for the suggestion, i did not try it on my watch, will do, from past experiences it was usually the other way around, things worked in GWD preview but not on the watch :grin:, i will give it a try

Hey @Razaa-Watch-Faces,
If you find it does work after trying on your real watch, I think you might be interested to submit a bug report here to the support team so that they fix GWS preview to work correctly.


thank you for the solution, it really works on the watch,but not GWS, will submit a bug report later this week

1 Like