Has Samsung sabotaged the Gear Fit 2?

I have an original Fit 2, which I love. I’ve designed several watch faces I use every day.

However, Samsung recently required an Android app update if I wanted to allow my phone to continue to connect to my Fit. So I did. Then the app said I had to factory reset my phone. I did, grudgingly, even though I knew I would lose all my watch faces.

Then I set up the watch (WiFi, Debugging, etc.), fired up my original Gear Watch Designer (v1.3), and it said my certificates had expired. It let me update my author’s cert, but when I connected my watch (successfully) and tried to update the designer cert, it found my device, but then went away into never-never land and never came back. The screen remained blank, no “Congratulations” message. I tried this several times.

So, I tried updated to the new watch design studio (v2). Found out it doesn’t support my watch. Thanks, Samsung.

I tried using v1.6.2 (the latest that Samsung says is compatible with my Fit 2). It supposedly updated both certs successfully, but fails about 60% into the install with a data dump indicating that some certificate (it didn’t specify which) was expired.

So I tried v1.5.0 and v 1.5.3. They, too, let me connect and update both certs and build my watch faces. But when I try to run any of them on the device (including the samples that come with the SDK) they fail and about 60% with the message “Existing tpk is not valid for this device.” Yeah, the existing tpk it just build for my device that it found and connected to.

It almost seems like Samsung has updated the firmware on my watch to render it incompatible with the existing watch design SDKs, meaning if I want my own watch faces, I’ll have buy a new watch.

I’ve tried all the above on two different Windows machines (XP and 10). Same behavior.

I tried running Tizen Studio on my Ubuntu 20.04 box and was unable to update my certs on it, as well. If anyone has any experience on building Fit 2 watch faces under Studio on Linux, please chime in!

Any ideas what’s going on, or how I can get my watch faces back on my Fit 2?

Thanks.

I think you mean the Wearable App update for your device. I have a test Gear S2 device and I have to “Update it” the wearable app when I go back and forth to newer Tizen or Wear OS platforms.

v1.6…2 should work with Gear S2 and Fit2 and Fit2 Pro. When you build I assume you are selecting the older Tizen version and you have debugging and developer options enabled on your watch.

I think the issue is that you are not accepting the RSA Encryption Key in time and that is why the certificate times out.

In your C:\users\username\ folder is a hidden folder .tizen
In that are two files sdbkey and sdbkey.pub move them or rename them and restart your computer.

Next time you go to connect watch your watch and it will either says something about allow connection or accept the RSA Encryption key you need to allow that.

If that doesn’t work let me know and I’ll see what I can do using my Gear S2 watch

Ron
Samsung Developer Relations

No, I accepted the RSA key. (I did miss that the first couple of times, though.) The Certificate is expired because I generated it a couple of years ago and it looks like it was good only for a year.

I don’t see a place to select the Tizen version, and I see no way of getting that info from the watch. (Did it update Tizen, or is it still factory-original 2.3? I dunno.)

As I said, it connects to the watch, but when I try to build (even the included samples), it says the tpk it just built is not valid for the device it just connected to. ???

Thanks for getting back to me.

Correct, you can’t select the Tizen version for a Fit2 watch face.

I use 1.6.2 for Fit2 watch faces.

Not sure if this helps or not…

There was a lot of build differences between Gear S2 and Gear Fit2 so I can’t test run on Device but…

When you generate a New Project be sure to select the Gear Fit2 device it is easy to select the Round or Square watch style by mistake

The only examples are Analog_Line and Digital Neon all the others are not compatible.

The Certificates don’t really expire but you may need to generate new Distributor Certificates if there is a system update.

Hope this helps,

Ron

Yes, I select Fit 2 and tried both the analog and neon faces. I generated a new Distributor Cert but again, it says the tpk it’s building is not valid. (If the cert were invalid, I would have a ! in the icon showing the connected device.)

Have you updated (factory reset) the watch recently? Mine was working fine until Samsung ordered me to do so to keep their new Gear app update compatible. I still think they’ve updated the firmware in the watch and screwed this up. (But that’s just a theory…a watch theory.)

1 Like

BTW, my software version is R360XXU1ERC7. Does that match anyone else’s Fit 2? (I wish I had a record of the original factory version number…)

Hello, I am sorry to read about your trouble.
It wont help you anymore, just wanted to mention, that I managed to avoid wear app update for quite some time, just by starting it only when offline (without data connection active on phone).
Same as the phone SW update. Why to repair something that is not broken?

1 Like

You are probably correct, because I have not updated my firmware :frowning:

When you reset or do updates you need to create a new Developer’s Certificate and acknowledge the RSA encryption key. In the older versions it would be something like allow Debugging pop up but now it is accept the RSA Encryption key because of 2019 GDPR privacy regulations.

Ron
Samsung Developer Relations

Can anyone confirm my supposition? Has Samsung recently updated the firmware in the Fit 2 watch? I have no other reason why GWD will no longer allow my watch to accept tpk’s it builds.

Because if so, I’m probably wasting my time and need to see if another watch (Apple?) allows me to make my own watch face designs. (I could get a new Gear device, but I’m not keen on supporting companies that arbitrarily change their apps or hardware, without consideration for the impact on their users. Although that seems to be all of them, these days.)

Alternatively, if they have updated the firmware, is there a way to push a prior version onto the watch, like flashing a rom in an Android phone?

I have no experience with flashing firmwares, but maybe this can give you some clues