Cant push Design to Watch

As per previous post in incorrect forum, I am having difficulty pushing Designs to my Galaxy Watch.
Originally it was a problem with ‘sdboverbt’ via a new Samsung Handset, however I was advised not to use ‘sdboverbt’ and connect directly to the Watch via WiFi…and this is the current situation.

Original Galaxy Watch which has performed a recent Software Update with the following versions,
One UI Watch Version 2.0
Tizen Version
Knox Tizen Wearable SDK 2.5.0
SE for Tizen 2.0.0

Firstly, when using ‘Galaxy Watch Studio’ which of these Software Versions are relevant ?
I would have thought as it is an original Galaxy Watch, then it would be Version 3…but not if it is the Tizen Version of 5.5.02 that needs to be referenced.
Galaxy Build Version

When I complete a Build and then try to Run on Watch, it stops at approx 60% with the following error

NOTE - I never had issues before when using this Watch and ‘Galaxy Watch Studio’ via a Samsung Note 8 Handset and ‘sdboverbt’ (as recently as 2 Months ago). However, after replacing my Handset to a Samsung SE23 FE and this then updating the Software of the Galaxy Watch, I am unable to load previous or new Faces created with ‘Galaxy Watch Studio’.
Personal use only.

Hoping someone can help.

I have exactly the same problem. I found all of my distrubitor certificates. I tried them one by one. Only one of them worked up to I get the same screen as seen in your post. So I when tried to get a new certificate; I get this blank screen. Trying to get the certificate using another method creates new certificates but it also doesn’t work. I still get the same result as pictured in your post. (Set up SDK | Samsung Developers) and (Creating Certificates | Samsung Developers)

I understand we cannot upload new watch faces to Galaxy Store anymore but, I wish I could use my own watch faces on my Galaxy Watch 3. And my Smartphone model is Note 10 Plus which is not one of the latest models yet.
Sorry, I couldn’t help…
Thank you for opening this thread…

1 Like

That is the issue Select Tizen 4 nothing in GWS requires Tizen 5 or later ( I may have said Tizen 5 in the other post but it was select Tizen 4)

Samsung Developer Relations

Thanks Ron, I’ll give it a try tonight and provide an update on result.

Still the same problem. I created a basic watch from the sample list and then chose Build option Tizen 4
Galaxy Build 4

but still got the following error after 65% run process

I also tried rebuilding one of my earlier projects as Tizen 4…same result.

One of two things
first one is you didn’t accept the RSA Encryption key. If you don’t accept it right away and it doesn’t show very long it doesn’t ask again.

in your users folder is a hidden folder .tizen
in it is and sdbkey rename them
Then restart your program or better still restart your computer and your watch
That will force the RSA Encryption key acceptance to pop up.

Be sure to observe your watch closely as the RSA acceptance doesn’t stay but for a few seconds. Select yes there is a don’t ask again option but it never asks again anyway.

The other is much more difficult you need a new Distributor Certificate see this thread.

Samsung Developer Relations

1 Like

Thanks Ron…followed the steps of the ‘Key’ regeneration…but same issue

Renamed Files and then rebooted both PC and Watch
Galaxy Key Rename

I’m confident the RSA acceptance was successful as the Watch didn’t appear in the Galaxy Watch Studio Screen until I accepted it.

Run Error

I guess I’ll now go down the path of your second recommendation.
Before I do, I’ve never tried distributing my designs as they are for home use only. Do you still suggest running through these steps ?

I gave an initial crack at following the steps outlined…but it’s all quite confusing.

Not sure what additional software packages have to be installed when installing ‘Tizen Studio’
Finding ‘Fit2Installer’ proved to be an adventure in itself (eventually found a link to it)
I was able to get new Certificates via the Manager but didn’t see an option to tie that in with my Watch (I might have left out a step somewhere ?)
Still not sure how it all ties in with each other…a pity I broke my Note 8 phone which has been the cause for my current problem.

Oh well, I’ll rest for a few days and give it another crack with a clear head.

You don’t get the RSA encryption acceptance until you try to send data to your watch. It will show on your computer when connected because you needed that connection to get the distributor certificate.

It only takes a few minutes to try this pairing a watch to a new phone basically does a full reset and would remove the RSA Acceptance.

You probably are right but you really really want to try this first even if you think you did it.

Samsung Developer Relations

After trying everything and failing on all of them. Here I come with a solution.

I changed the phone’s date to 5 years earlier ,which changed the date on my Galaxy Watch 3 45mm. I tried to install the watch face I created for myself. (MURADO) GWD warned me that the certificate start date was April 4th 2022. So I changed it to that date and it worked…
I don’t know how to express my happiness. :grinning::grin::smile::rofl::laughing::sunglasses::star_struck:

PS: You have to build a new tpk file before you run on the device…

Will give this a try and report back.