How to lauch GalaxyWatchStudio?

Hello. I’m new on this forum.
I downloaded GalaxyWatchStudio on my PC using Windows 10. I launched the installer, and I have now “GalaxyWatchStudio_2.0.0_windows_x64.exe” in a folder on my HD (in Program files (x86)). I unzipped this file. But I don’t see any executable file anywhere.
When I try something, I receive a message asking me to download the version 1.8 of Java. I do this, and I can see the files on my HD, in “Program files (x86)”. But when I run it, a have a message saying that it does not run with Chrome. I tried using MS Edge. And it’s the same.

I can’t do anything. What can I try ?

There is something wrong,
You should have downloaded
which contains GalaxyWatchStudio_2.0.0_windows_x64.exe which is GWS installer.
This is a 64 bit program and should not have been in the program files(x86) folder but that is not the problem

Using Add Remove Program remove any version of Java you have
go to
or go to Oracle’s Web site
Select Java SE 8uxxx and then click on the oracle Download to ensures the latest version
We recommend Java 8 because it is the last publicly released version for newer versions you have to sign up and be an Oracle member.
Download jdk-8u261-windows-x64.exe do not download the x86 version as that is 32 bit version.
Once Java is installed you can then click on the GalaxyWatchStudio_2.0.0_windows_x64.exe which will launch the installer.

If it still does not recognize Java then there is a path error and I can help you with that

Samsung Developer Program