JavaScript error

I’m getting a JavaScript error every time I try to “Run on Device”. A screenshot is attached (hopefully). Sometimes in the past, I’ve been able to just hit OK and the watch is still sent to my watch, but now my watch never shows up in the available devices. I have all the debugging stuff enabled, and the watch has been connected via ADB. Has anyone else come across this and been able to solve it?

javascript error

Github says.

ECONNRESET error happens if the connection with the server is unexpectedly terminated and might also be an indicator of internal adb/device/connection problems.

Looks like an adb problem. if others have the issue please respond and I’ll pass it on to the WFS team but if it is adb then it goes to Android developers team.

Samsung Developer Relations

I tried to uninstall and reinstall, but I’m getting the same error. However, I installed WFS on a much older, slower computer, and it actually worked there. Strange. Thanks for your help!

Based on the experience above, I downloaded a newer version of ADB on the computer I was having issues with, and that seems to have fixed the problem. Still good to know in case there are others with the same issue.


I have the same error as you.
I think you’ve solved it. Can you tell me the solution in detail?
I lost three face files because of this error. I’m very angry… :joy:

I just replaced my existing adb installation with the latest version from here:

Since then, I have not had the issue again.

Thank you!
What should I install here?
I pressed ADB, but there’s no response.

Forgive me if this is too basic or not basic enough. I don’t know your situation. Your watch and computer need to be connected to the same network. Turn BT off on your watch, and enable wifi. Enable developer options on your watch, and within those options, enable ADB debugging, and debug over wifi. Allow the permissions as the watch requests them. Make a mental note of the ip address your router assigns to your watch. Open a command window and navigate to the directory where you installed adb. Then type - adb connect 192.168.x.x:5555 (where 192.168.x.x is your watch’s IP address). Again, allow whatever permissions the watch requests. Now when you “run on device” within Watch Face Studio, your watch should show up. If not, scan devices might help. Until I installed a newer build of adb than what I had before, I was getting the same error you’re getting. I have not had that error occur since.

Hopefully all or some of this helps you out!

I am successful leaving Bluetooth on. All the other instructions you provided I also use, I just don’t turn off Bluetooth. It works fine with it still on.

Thanks for the detailed explanation
You are such a good friend!
I wish you happiness!