Jumping of the hands when the clock wakes up

I made a very simple analog dial in WFS for Galaxy watch 4, but I ran into a problem. When the clock wakes up (with a gesture or a button), the hands jump to the places where they should be at the moment. There is no such problem with stock Samsung dials. I was looking for similar topics, but I didn’t find an answer to my question.

Hi. I think It’s battery saving feature. AOD doesnt refresh screen so often to save battery power. That why for example minutes are jumping minute by minute (6°) & when screen wakes up hands automatically jump to the accurate position.

I mean normal mode and not AOD. The hour, minute and second hands jump. Why is this problem not present on Samsung stock dials?

Because the stock dials are not developed using GWS or WFS. What you are seeing has been that way for years.

Is there no way to fix this bug (feature)?

1 Like

Since it’s been a feature for years, what do you think the chances are of it being changed?

Has this issue been raised before and how did Samsung representatives comment on it?

Watch Faces are Apps and it takes a few seconds to load an app all the complications and such have to be initialized.
The preinstalled watch faces that are not apps they are part of the User Interface and as such and for lack of a better term are always running.
Some of the preinstalled watch faces are now apps and you see the same behavior with them as you do with WFS created apps. Observe your watch and in the wearable app change the watch face to Digital Dashboard and you’ll see the same changes when it is selected.

Samsung Developer Relations

Please show me what this dial looks like.

black and white digital background with the ring having 4 segments for various progressions and several complications below the time.

If you don’t have a Samsung Smart Phone it could be it wasn’t installed.

Are you talking about this?
SmartSelect_20211222-220959_Galaxy Watch4 Plugin

Hello. RON
The problem is that version 1.0.3 does not have a problem with jumping hands.
If you make it with version 1.0.12
The hands jump when the watch screen wakes up.
This is a very serious bug.
I am making with 1.0.3.

It should be resolved.
it’s a fatal problem

1 Like

In version 1.0.3, there is no problem with the hands jumping.

This is a fatal problem in version 1.0.12.

I am using it down to version 1.0.3.

I could not duplicate this no matter what I tried digital aod, no aod, analog aod, second hand normal, second hand sweep. I did not try it with a custom watch hand is that what you are using?

If custom hands are they resized to 450 pixels before or do you do that in WFS.

Samsung Developer Relations

yes, when I load that it takes quite a while to reset clock and other complications. But I did change the complications and that may be the reason.


It’s not an AOD issue.
I rarely use AOD.
without AOD
turns off to standby
Raise your wrist to turn it on or tap to bring up the screen.
The second hand. The minute hand jumps.

Symptoms that did not exist in 1.0.3
It happens in 1.0.12.

When the watch face is woken up, the needle jumps, which is very unnatural.

I agree. This issue exists since the last Update of WFS.

I have no problem with that.

I made the same dial using WFS 1.0.3 and the hands don’t jump!!! This is a problem of version 1.0.12

Then turn the AOD-Mode off. You will see, what we mean.