Analog hands rotation bug in aod mode

Today I’ve updated wfs to new version (1.14.20 from 1.14.13). In normal mode every thing works fine, but in aod mode analog hands rotation seems bugged. The rotation of hour hand works as minutes, minute hand as seconds and second hand as hour.
I tested with sample projects, and the result is same. Is this happening to me or its bug in the new version?

Are you seeing this on the watch or in the run time emulator?

It may be because you didn’t update from 1.4.13 to 1.4.19 or it may be because you have a second hand in your AOD

Check what your settings are in the AOD hands what do they say for sync with?

It all seems to work fine with the example projects provided in the run window. But they don’t have the errant second hand in AOD mode.

Samsung Developer Relations

1 Like

I checked the settings in aod, all the syncs with hands are correct. In the sample projects (of course there is no seconds hand) minute hand moves as seconds.

The minute hand in the run preview runs at one minute per second is that what you are seeing?

(boy I typed that first line to fast)


1 Like

Trying again.

The minute hand in the run preview runs at one minute per second it does not run in real time. You can see this because in the work window the indicator at the bottom jumps a minute each time the minute hand moves

I think this is done because there is no second tick in AOD and it helps emulate how things appear better.

I don’t know if this was a change from the older version but it you tell me it is I wouldn’t doubt it.

Samsung Developer Relations

1 Like

Thanks for the help, indeed the run preview runs at one minute per second, how I didn’t see that. This is my first time making an analog watch face, maybe that’s why. Now need I to make the seconds hand image invisible in aod? (Thanks for your reply)

Set the work window to AOD
You don’t see the hide/show in a normal layer (see the hour hand in the image)
if you hover over a layer (in this image I hovered over the minute hand and a grey eye will show (see minute hand in the image)
if you click on it and it will be brighter and the text for the layer will be greyed (see the second hand in the image)
that will hide or make the second hand invisible but only in AOD mode.

show or hide

Samsung Developer Relations

1 Like

That did it, thanks for the help

I have the same problem, how was this corrected? I checked everything. Even the one sec per min
I have the latest update and it still happens… when I run the AOD Emulator. only it’s fine when AOD is off.

Hi can clarify that this is happening in your watch not preview.

What one sec per min means…is your preview will show that the min hands moves every sec. But its still a min hand. You can not change the preview to 1sec per sec in aod

1 Like

It is in preview… in WFS The Minute hand moves every second instead, I have the second hand not displayed in AOD Yet the Minute Hand has the correct setting in WFS

1 Like

Ignore the preview…there no 1sec/sec in aod preview
On 1m/sec or 1h/sec… (this preview rate)
Why they do it like that i dont know

What impt is its working on the watch

what we are talking about is in the screenshot

1 Like

What I learnt is, you should make the second needle/image invisible in AOD, as it is useless in AOD.
It is weird that the wfs choose this preview style unlike other platforms like facer and Fitbit studio where the minute image moves as minute hand in AOD. The only way to check if the watch face is working as desired is to send the watch face to an actual watch and test it.

1 Like

I guess is because its decided that the sec hand will not move on the watch. And for quick preview of everything moving they decided to “fast forward” the preview

1 Like

In AOD mode, everything is updated only once per minute. A second hand is therefore useless.