Largebox complication has changed?

Hey, maybe I am missing something super obvious but for some reason I cannot make any basic customizations to the default weather complication for a large box complication. Before I had no trouble choosing simple things like fonts, font sizes (title and text), icon sizes, colors and orientations within the large box complication. Now however, nothing is working? When I set up my large box complication now in WFS 1.5.7 and make those simple customizations and then run on my device (GW5 Pro), and set the complication on my watch using the Google default weather app in the app list, it just loads up the default appearance with icon Big, icon small(again?), text (which is location), and title (which is temperature). nothing I do had any impact on this? I just made a face using this same set up a mere 2 weeks ago or so and was able to have my font, font size and layout the way I wanted, and now…I cannot?

This is driving me nuts TBH as I don’t think I have missed something?

I even tried it with a smallbox comp with text only to see if JUST the location would load up, and it still loaded up the default appearance with an ICON! How is this a thing if I only selected a smallbox comp with title only?

any ideas, responses, consoling words would be greatly appreciated. Thanks.

1 Like

Hi @MergeLabs , probably the default layout has changed and u missed something. Either figure out which layout its selecting and remove all the unwanted layout. Or change the font etc by selecting all the layout and do for all of them

Also the temperature and country i think after update they swap places

As for text (which is location), and title (which is temperature

U are not able to do anything for this…but move the field around but u may still change its font size etc

P.s i used the icon, image , title, text layout…and changed it no issue

1 Like

This is because wfs preview is not the actual complication but it only to show u what the various layouts look like. At the end of the day complication will choose its default layout from the layout list provide (the ones on the left of wfs)

But there a way to force to use your selected , provided the complication understand the layout.

To do that read the topic i post in previous reply.

If u force to a layout not supported by the complication u wont be able to see the complication when u try to customization the slot.

Make sense?

Can view this too

1 Like

Sorry, the Christmas thing got in the way. I understand how to do the large box complication and as I said I had no trouble before. Now However, when I do a simple test and change font, color, text alignment, it appears as it should in WFS. The problem is when I load it up on my watch using the default weather app, it just shows the straight up default view, with no changes to color , text alignment etc…

choose complication
select DEFAULT weather app
this is what I get
For some reason, none of the font changes I made are shown, and I have 2 icons???

I am starting to wonder if its not WFS and some how I have set some weird default on my google weather app?

1 Like

@MergeLabs Its not wfs.

Its because

  1. the weather default layout has changed after a update

  2. its because the preview shows all possibles for your consideration when designing. When u click on a layout it just display that layout to show what it will look like if the complication used that layout (does not mean that the layout u asking the complication to use) , it tells other complication that they can use any of the layout u provided.

  3. so even though something change there still away to achive what u want.

Only way to “force” is to do as in my guide.

Your screenshot shows u doing it wrong
As in your example u have provided 6 layout for any complication to use. As for case its weather, so this complication can use any of the six if it was program too. It usually choose its own default

Anyway on the watch the complication has automatically select the layout i arrowed one.
(Complication default selection from your list)

I saw u liked my guide, did u notice the difference it the way i did compare to u?

Screenshot on my Gw 5 pro


Sorry i must say this even when i show working example and explain things clearly people come back telling me its not working and claim to know how to do it, but after re-test or showing screenshots its not what i explained and keep blaming wfs. Instead of their own mistake.?⁷

P.s if my Guide not clear please suggest how to correct it thanks

Edited the guide

1 Like

@MergeLabs tried it again?
Anyway easiest way is to go select the way u select and hide the icon shift the placement of the rest of element then change the font size etc on the layout i arrowed btw.

see this screenshot

I circled what you should do…

Whats on my gw 5 pro


1 Like

Hey man, much appreciated! I got it figured out. I don’t recall having to select that specific template before so I guess that’s what messed me up. It’s really great to see some out here like to extend a hand to others. Thanks again!

1 Like

U will just “lucky” previously the default layout was already the one u will playing with in wfs. But along the way they decided to change it.

So trail and error for us. To find what templates the complication use as default

P.s if u go by removing the other templates. When users try to customise the complication they were notice some missing complication from the list. Because some of the complication doesnt recognised your selected template.


Hi everyone, I got around the problem by widening the “slot bound” surface on the WFS made previously and I solved it.

Sorry @Mayalona that not the issue for this topic. It more why changing font , it size no effect

1 Like