Light_Effect with [s] Opaque Tags?

I am always impressed by the GWS in its ability to render properties without much code. But I am wondering if the problem is with my Active2 or if GWS doesn’t support opacity changes in both the seconds tags and in the gyro settings. I am wanting the Light_Effect to get brighter at each 0 seconds, and normal at all other seconds.

A Light_Effect by default has opacity settings within the gyro movement. When I add a tag expression in the Opacity setting so that the opacity changes at the [s]==0, the effect works well in GWS while previewing, but when I publish over to the Active2, the opacity is always stuck at that [s] ==0 value. I’ve restarted my watch and that didn’t fix the problem. I can only get the opacity tag expression to work if I remove the opacity setting changes within the gyro.

Even so, the result looks fine without the gyro opacity settings, but I am wondering what causes the discrepancy; too many calculations from too many sources is my guess, but the preview within GWS works, wondering why not on the watch?

Apart from that oddity, something else which puzzles me is why the Light_Effect can be used on top of and fully covering a button? Seems to me that the Light_Effect would block the ability to press a button under it, but it works well.

can you post your exact tag expression you are using for opacity?

Read the tutorial on buttons regarding tap area. You can have other images or even buttons partially on top of buttons

Samsung Developer Program

Hi Ron,

Here’s the Light_Effect’s Opacity tag under Appearance:


It will only work on my Active2 if I remove the opacity settings within the Gyro settings. Otherwise, the active2 will show the opacity as too bright all the time.

Sorry it took so long to respond but I duplicated this and will report it as a bug.