Loss of WiFi connection on update

Got an update for my watch this morning and installed it. As usual it screwed with some of my WFS creations so I figured I’d simply reinstall like I always do.

Surprise! Could not connect via Wifi! Tried redoing the IP address, restarting both WFS and my watch - nothing. Any ideas??

Do your watch got the update for Wear OS4? The wear OS4 have a different connection steps for WFS.

I am using Wear 4. No idea if thats new or not. What are the new steps?


First you need to connect to your WiFi network including putting in your password The System Upgrade removes that.

Also it removes Develop Options you have to turn those back on (setting - About Watch - Software information - tap 7 times to enable developer Options ) and restart your watch

Now we need to know what version of WFS you are using. If this is for your own use update to WFS 1.5.7 Beta (the Beta is for the plugin support)

On Watch click on settings then developer option
Turn on ADB debugging and ok that
scroll down to where it says WirelessDebugging tap on it
wait few minutes and
write down the IP address followed by :xxxxx the port number

Then click on Pair with new Device (apparently you have to do this ever day )
it will have a pairing code
followed by the IP port and a different port number

Run on Device
fill in the IP address in the top
Fill in the first port number when you first turned on ADB Wireless debugging
Fill in the Pairing code
Fill in the last port number when you paired the device

If you are using 1.3.13 there is a different way to do this.

Samsung Developer Relations

Yeah. Did all that and still get the Failed to connect. Tried it with my phone hot spot… same. Removes and reinstated the app. Nada.

It’s got to be the watch. That’s the only thing that has changed. I can see the wifi connection on the watch but, for what ever reason, it isn’t getting to the app. Different something.

And Developer Options wasn’t changed. It was still on my watch.

I replied on the other thread


Since this worked before I can assume that it isn’t firewall or network error on the computer side.

Go to your Developer Options ADB debugging then scroll down and revoke debugging authorizations

Now try it That should force the add device option for debugging. Remember the first time it takes a while for the connection to happen The run on window will say no devices but once you click OK it pops up without doing a second search

Samsung Developer Relations

Yeah. I got it. Thanks again.

One last question… do you know the ID that will give me SHealth Daily Activity rather than the full layout of SHealth metrics.

See this thread @amoledwatchfaces
Has a solution for steps and other health that works cross devices.

Samsung Developer Relations

Great thanks alot. (Hate that 20 character limit!)