Galaxy watch studio does not connect to galaxy watch

Hi everyone,
i can’t connect the watch to galaxy watch studio
i have this problem when i connect my watch to galaxy watch studio in macOS catalina …
this is the error: java.io.IOException: error=13, Permission denied

For some reason it is extremely hard to get GWS to connect over Catalina for the first time because of the RSA acceptance shows for a very short time.

Go to Settings -> Gear info -> About device.
Tap on Software version 5 times. Then a confirmation pop up displayed once the Developer options is enabled.
Make sure Debugging is on in About Watch settings
Reboot your watch (by holding down the home key until it says rebooting)
Make sure Debugging is on after the restart
Important …Restart your Phone too
Restart your computer too.
Wait one full minute before attempting to connect.

Open Settings Connections make sure WiFi is always on. Tap on the connection and then get the IP Address and write it down

BE SURE YOUR ETHERNET CABLE IS UNPLUGGED OR THE ADAPTER IS DISABLED it isn’t enough to just be connected to the WiFi on your PC

You need to connect the Watch to the same network as the Computer WiFi Modern Modems have 2.4 and 5 Ghz bands you may need to have the PC connected to the 2.4 network.

For Mac users it is reported that opening the WiFi settings on the watch and forget network and reset it allows GWD to find the watch where it previously couldn’t
Launch GWS select run on device and enter the IP address (click on the + sign)

Watch your watch like a hawk and the RSA Encryption key acknowledgement should pop up.

For most people that can’t connect the problem has been allowing permissions watch for them on both the Watch and the Phone especially the RSA encryption acknowledgement when you first try to connect. (it remembers after the first time and doesn’t display again, even if you don’t accept it). It is reported that if you have your watch on a factory installed watch face and keep it active while trying to connect the RSA key acknowledgement stays on longer.

Finally for Catalina if all else has failed Download Tizen Studio open device manager and keep trying to connect. It may take three or more times but it will do it.

Ron
Samsung Developer Program

I had an similar experience with windows 10 today, It found the watch quickly but wouldn’t connect. I was quite surprised that on multiple failures I was never prompted to check the watch for this and only caught it by chance. Configuring and setting up Tizen is a lot more difficult than my experiences with other development tools.

1 Like

thank you very much, I solved by installing Tizen Studio, with this method I managed to connect my Smart Watches in my Mac Pro

J’avais une Gear Watch S3 Frontier et j’ai toujour eu des problèmes de connections avec tout vos versions de Galaxy Watch Designer. Maintenant j’ai une Galaxy Watch Active2 et depuis 3 jours que j’essaie de me connecter à l’ancienne et nouvelle version de votre programme ( GalaxyWatch Designer et GalaxyWatch Studio et rien à faire et tout ça en suivant vos recommandations et vos exemples. Et maintenant je suis trop vieux pour aller chercher un Bac en Inginérie Informatique pour arriver à connecter ma montre à votre programme et je vous avoue que c’est la première fois que j’arrive pas à compléter une connection qui je crois devrait être très SIMPLE. Alors où est le réelle problème? Moi vraiment ou que simplement les programmes et consepteur ne comprennent pas qu’il faut simplifier tout ça au niveau des UTILISATEURs. Je me suis fais des modèles de montres personnelles que je ne peu même plus utiliser à cause de problèmes de connections. Alors SVP abaisser vos niveaux d’utilisations simples au niveaux des utilisateurs. Merci de votre attention et vos conceptions…

I’m sorry you have had issues connecting to your watch.

In the older Tizen 3 version there was a similar message but it stayed longer. With GDPR and US Privacy rules not accepting the encryption key can be taken as a no and the permission is not shown again. This is not a fault of GWD/GWS but may have been a lack of documentation. In that regard we have improved the documentation greatly in the past year.

We updated the FAQ 23 Why can’t I connect?.

Ron
Samsung Developer Program

So is it possible to have the necessary detailed instructions step by step so that I can finally connect my watch (Galaxy Watch Active2) to your program and that it works without problems really without I need a course of professional to finally be able to reinstall my personal designs on my watch and reuse them. Your program is really great, but in terms of connection it’s really not easy, and yet I have a lot of hours of use on your program. And thank you again for your help, that’s appreciated.

If you are using any Apple device to use GWD / GWS and connect your Smart watch, I recommend that you start Tizen Studio and that you connect through the Diveces Manager …

No I have never used any Apple devices or anything. I know Apple and its technology very well. I use a Samsung Galaxy S8 cell and a Galaxy Watch Active2 watch with a PC computer:
ASUS Maximus XI Formula + Intel Core i9-9900K CPU + Corsair DDR4 3200MHz 32GB Memory + GeForce GTX 1080TI Graphics Card and I still cannot connect my watch to your GalaxyWatch Studio or the old GalaxyWatch Designer.
And in addition even to the installation of the update I had a message that it could not find my author file.
In addition I provide him with the exact IP address of my watch which should completely avoid any connection error but instead he gives a message that he cannot find the device. Yet my phone finds him and my computer too, but not your GWA program? So where is the mistake of everything really. If you have an installation tool to put your GWA and my watch in contact without problem please send it to me by attachment by mail.
And thank you again for your important support, otherwise I will have to say goodbye to the use of your wonderful program and my watches that I have already created because there I am really out of ideas.

1 Like

Download Tizen Studio and connect through the devices manager, without closing the devices manager open gwd / gws and try to connect again…

https://developer.tizen.org/development/tizen-studio/download

Well! Well I downloaded this file: File Transfer for Galaxy Watch_v2.2.8_apkure.com.apk of 1.31 MB
Then I installed it on my cell and then installed and started. So I had instructions 1 to 5 for use
Then I went into my watch options to make sure the developer option to make sure it was active.
To my surprise I got the connection with my watch but! there is always a but! lol i got these 3 messages.
1 - Coonected Wach / Galaxy Watch Active 2
2 - Install & Launch Package at about 65% and then:
3 - Install fail / Existing tpk is not valid for this device. Rebuil the tpk and try again.

Here we managed to make it to this stage. Even so far, so are we going to make the perfect connection?

So from what I see these Tizen Studio file which is not compatible for my Samsung Watch Active 2 …?

Your help is always greatly appreciated and thank you again.

you have to see if the file you sent is a .tpk and not a .gwd, if the file sent is a .tpk you should check that it says “file name” tw4.tpk to make it compatible with your watch…
Roberto
Ya Soft

Ok Great! I understood the message (Rebuilt the tpk and try again). I had to use the tool (Build (F10) and there everything worked fine.
So I confirm that now everything is working perfectly and thank you again for your patience and the help you have given me.
Suggestion, if you could add an installation package to use for connections GWA vs Watches simple to use that would be great and much less complicated.
So thank you again and it’s a really good job you do, I’m a 72 year old retiree and all of that helps me a lot to keep up well …
Thank you…

1 Like

you can download https://developer.tizen.org/development/tizen-studio/download