Cannot connect Watch 46mm to Mac

I’m running Mac OS 10.14.6 Mohave, a newly downloaded Galaxy Watch Studio 2.0.0 beta (build id 200403), trying to run a sample watch face project on a new Galaxy Watch 46 mm, developer mode on, author certificate generated, freshly connected via Wifi, with IP But GWS does not find the watch. I have not seen any mysterious RSA bits to approve or not. I have tried a dozen times, also tried following some advice in this forum, incl. forgetting the network and reconnecting to it. Seriously?? I find this a very cumbersome if not straight ugly setup, especially as it is not working in any way for me.


I solved it like that under Catalina. I have installed Tizenstudio and start the Device Manager application. As soon as the watch is connected there, you can select your watch in the GWD.

Well, on the link to gives me a 404 error…

There is an issue with Tizen Studio and macOS Big Sur and they may have suspended the downloads. The same issue affects GWS and Big Sur so don’t update to Big Sur until this is fixed.

You just need the SDB program so open a support request Samsung Developer Support and ask them to send you the SDB for for Catalina.

Now find your GalaxyWatchDesigner in the MacOS Applications folder.
Right click on the file and choose “Show package contents”
Open the “tizen” folder
Open the “tools” folder
Drag the Tizen Studio sdb version of the file and drop in in the tools folder of the package tools folder overwriting the other sdb file.
Close the package
Now you run the designer, it will connect without the sdb error.
Keep a copy of this good sdb file in a safe place just in case you need to do this again after the next update.

Samsung Developer Program

use this link:

Download | Tizen Developers

Finally solved with the help of Developer Support, thanks! I just can’t believe how convoluted and cumbersome it was to get solved, and it still feels a bit unpredictable.

can you describe the solution

A combination of rebooting the watch, confirming some RSA thingy, activating the debug mode, replacing the sdb tool provided in the forum, rebooting the MacBook, changing the executable flag of the sdb binary, and running it multiple times until it worked like this in my case: sdb connect I still need to run sdb connect after rebooting my Mac, so it seems not to be executed by GWS properly or at all. I have not checked any running processes.

1 Like