MAUI app with Tizen failing compile

Hello, I am trying to set up a .NET tizen project with a Maui app, I created a new project using the MAUI.NET App template, which at first obviously worked fine with no errors.
After editing the project file and removing the commented Tizen TargetFrameworks as follows


and changing the runtime target to it, net6.0-tizen, after trying to build the application I am getting a BUNCH (356) of syntax related errors on files like Styles.xaml.g.cs and MainPage.xaml.g.cs (auto-generated files…)

Now even after removing the net6.0-tizen from the TargetFrameworks I am still getting these errors! I’ve tried deleting the bin and debug folders.
When deleting the net6.0-windows10.0.19041.0 from target frameworks Visual Studio recognizes the running emulator and attaches to it correctly.
I’ve also noticed that the errors all seem to originate all from the global:: references, where the // in the url gets treated as a comment and therefore the line endings don’t get noticed.
Any help on setting up a tizen.Net project with Maui is highly appreciated, Thanks!

I fixed it!

  1. Uninstall VS
  2. Uninstall Tizen COMPLETELY
  3. Fresh VS installation
  4. Install the Tizen SDK using the Tizen SDK from Visual Studio’s extension (not from Tizen Studio!)
  5. Set up the certificates
  6. Un-comment the Tizen target framework option from the project’s file
  7. commented all of the other build targets, including windows (I really don’t know how to get it to work without it, any feedback is appreciated)

EDIT: do NOT forget to ‘Permit to install applications’ in Tizen’s Device Manger!

1 Like