No health data shown on watch face?

Hi, just had a customer email me that they downloaded a face for their Galaxy S8 Plus - Galaxy Watch BT combination and it isn’t showing any health data. I have a layer that when double-tapped, hides the image so that the health data is visible. But all the data shows zero.

I’m still using 1.6.2 since I still want to design for the S2.

Any ideas on whether this is a design problem, do I really need to upgrade to 1.8.1, or is there something the customer can do - they see health data on other faces.

Thanks!

Ask the buyer if they allowed the permissions when they launched the Watch Face That would block the information. They can set watch face permissions in the Watch Settings -> Apps

I haven’t heard of this issue with any version.

Ron
Samsung Developer Program

Thanks Ron, moved to the right forum too :slight_smile:

They said that "permission for sensors are on and location on my phone too. As I stated earlier, removed app and reinstalled, also did reboot. "

It’s strange

I’ve actually had the exact same issue recently.

A customer left a comment on one of my best selling watch faces (made with newer version of GWD, after 1.6.2) that all health data displays “0” for them. It’s a watch face with lots of health data, and this was the only time someone reported this issue. All other comments were highly positive, so I’m 100% sure it’s not caused by the watch face itself.

I’ve suggested the buyer that he/she needs to allow all permissions when installing for the data do become visible, but since the comment section is limited (only one reply and potential edits), I’ve only managed to find out that the user claims to have done “everything they can” and that it still displays “0”.
I’ve suggested the buyer to contact me through email with more info so I could find out more and hopefully help them, but they haven’t contacted me back.

I’m guessing they haven’t tapped the little “check” icon after the installation to allow all permissions, or they might have missed it, because I have no idea what else could have caused this.

Has find a solution for this? It’s my first time to have this issue.

Hi Mario,

Suggest that they go to Settings on the Watch then scroll down to Apps and open that, Scroll down to permissions and open that then scroll down to your watch face and make sure the permissions are set.

You may also want to suggest the reboot the watch by holding down on the home (bottom) key until rebooting shows. (hold the key down about 15 seconds) that might also help.

Ron
Samsung Developer Program

Thanks Ron. I will post the update which it’s fixed.