Heart rate measurement showing zero (bug?)

Hello everyone,
many of my users report that heart rate measurement is not working properly. After installing the watchface on new GW4 and also other Wear OS watches, measurement shows zero and the manual measurement does not work.

In some cases, measurement starts after a certain time and the manual measurement also starts to work (tap to measure HR)
However, for some users, the measurement shows zero even after 4 hours. (setting different auto measurement intervals doesnt help)

Can anyone confirms this ?

5 Likes

I have already reported this issue several times.

We hope for a fix asap.

1 Like

Hi! I have the same error as you. I have tried various expressions but everything remains the same.

I hope a solution soon

Reboot watch fixes this issue I found once I took at least one Heart Rating

same identical problem. No HR info available, show only 0, same after reboot.

Same problem here on GW4 and an older Wear OS device, with multiple watch faces.

The weirdest thing is inconsistency - sometimes it loads heart rate indicator immediately after installing a watch face, other times it stays on “0” no matter what.
In most cases I’ve found that basically “spamming” the manual measurement and/or changing watch faces seems to refresh the heart rate indicator within less than a minute, but this also doesn’t seem to work 100% of the time.

Either way this doesn’t offer a good user experience, hoping for a fix in the next WFS update!

Seem to be having a similar issue with custom watch faces (e.g. ustwo Looks) where the complication shows two dashes
Screenshot_20210909_135311_sysui

Trying to reset watch face permissions or manually measuring doesn’t seem to solve it either.