No step update after firmware update

Not sure if anyone has had this experience, but after installing the watch update to my GW4 on Sunday, none of the watch faces I’ve created with WFS show, or update the step count. This is true for the text update, step percentage and also the progress bar. I’m left with a “0” in the step count and the progress bar never shows up at all.
If I switch to a Samsung watch face, everything is fine. This is true for all the faces I’ve created and loaded on my watch. All of them worked fine before the update.

I experienced something similar cant remember which complication. But what i did was go to wfs delete the complication. Redid it exactly the same. And re-install to my watch and it fixed it.

Since then no more issue on newly created watch faces

Wfs 1.5.7
Gw 5 pro

Thanks for your response and I will try that, but this happens on all of my faces that I created. So I hope I won’t have to do that to all of them. The strange thing is that the watch does keep counting steps, it just doesn’t show them on the face.

OK, so I reloaded all my faces to my watch one by one and after that, they were all working. Not sure why that fixed the problem and not sure why it was a problem to begin with. Just buggy firmware updates I guess. Hope that doesn’t happen every time I have an update…

I think this is a known issue with previously installed watch faces built with WFS 1.3.13 I think if you have something published in Play Store and don’t want to update with WFS 1.5.7 I’d suggest you do a version update so the watch faces can be “reset”.

Samsung Developer Relations

Thanks Ron, I was pretty sure other people must have had this issue too. Not selling on the Play at the moment.

I created a watch face with WFS 1.5.7 beta. on watches using Wear OS Version 4.0.
After updating to version 4.0, there were problems with step counting which sometimes synced slowly on the watch and phone, even freezing. But a few days ago there was a Samsung Health update on the watch. Now Running fine.