V1.4.13 Step % device sync bug

I have identified a bug in the latest version of WFS.

When creating a watch face, go to Project > Settings
After checking HEALTH tab > Set Step Goal > Sync to device
When you run Run on Device

ProgressBar’s Goal is displayed differently.
The value of the connected mobile phone is not interlocked.

However, step count works fine.

Please check if it’s just me looking wrong or if it’s a bug in the tool.
We really appreciate this update.

화면 캡처 2023-05-11 185521

1 Like

I have the same problem.

@mywoongjin @SGWatchDesign

I noticed it myself and this is explained in FAQ 11
Basically that requires Wear OS 4 updates.

I didn’t read the FAQ the last 4 deal with WFS 1.4.13 beta

Samsung Developer Relations

1 Like

Thank you for the prompt response.
Galaxy watch 4 supports up to wear 3.5, so it was fixed at 6000. I need to develop without checking for users of multiple devices.

WFS is a tool I really appreciate.
I am always grateful.
have a good day.

My Galaxy Watch 5 Pro is currently One UI 4.5 and Wear OS 3.5.
Will it be updated to Wear OS 4 as it is updated to One UI 5.0?

Good afternoon. I tweaked my watch screen app on the new Watch Face Studio V1.4.13 beta.
Everything worked fine. Even set step goal worked well. I am also happy about the restoration of the heart rhythm. Everything worked perfectly.(Pictures as an example.)


Without much hesitation, I uploaded the update to the Play Store. It was approved surprisingly quickly. Everything happened as planned. the clock screen app asked to update it to the latest version. I did that.

And then it all started.

After the update, none of the data related to steps and their tags worked. Also the progress bar is no longer responsive. Fortunately, the heart rhythm works.(Picture as an example.)


Tried uninstalling the watch face and reinstalling it from WatchFaceStudio, but even that didn’t work. Nothing works anymore. Everything is frozen. Except for the heart rate. I even wonder how Google’s test team didn’t notice this.

Something went wrong. Even reinstalling WatchFaceStudio does not solve this problem.

Question. If the app update is for wear os 4, why does the play store allow it to be updated to an older version?

How to prevent update to older Wear os?

Why does the watch, after receiving an update from the play store, no longer display fitness data from the WatchFaceStudio program when running tests on the watch? For all watch screens?

I test watches on samsung galaxy watch 5, wear OS 3.5,.

After updating the apps from the play store, check the watch operation. Perhaps you will receive the same miracles. Thank you.

I believe it will (that has been Samsung practice in the past. However, I don’t have any information on release dates.

Samsung Developer Relations

I don’t know if there is a way to just go back to the older version in Play Store.
Personally I’d suspend the WFS 1.4.13 version and and replace it with an older version (hopefully you have a back up) I think you need to make the version number higher.

Samsung Developer Relations

No problem. When creating new releases choose from the library and can load old versions. You don’t even need to create anything from scratch.

Just interesting to watch. The watch store had some kind of new system update. After that, the data started working.

But will fail to load the app from google play store. Requires additional permissions that cannot be approved. (Photos from the store. Sorry that the pictures are in Latvian. These are the permissions required to perform the installation. Which cannot be confirmed.)

It is interesting that these permissions are required if the app is loaded through the watch.

Using a web browser, no permissions are required and the clock can be set.

But the WatchFaceStudio app tests started working and can be tested.Without additional permissions.

I will wait for the new watch updates. But will the old watch screens work with the new Wear OS 4? Thank you.