Pixel Watch 2 - multiple issues

So, some folks started receiving Pixel Watch 2 units and unfortunately, there are multiple issue reports:

  1. steps counter showing 0
  2. battery complication not working
  3. steps complication not working
  4. customization from phone side not working

Can you guys confirm this?

1 Like

I just received a letter from a client stating that no complications could be installed. Empty choice everywhere. I don’t know what to answer :frowning: I quote the letter below:

I’ve just got my first smart watch, Pixel Watch 2 with my new Pixel Phone. I liked the style of your Voron watch face and bought this.
When configuring and setting the complications on the Pixel Watch app from my phone, the complications are all “Empty” and don’t offer any choices when selecting them. Screenshots attached.
Hope you can help.

I have a Pixel Watch 2 myself and my own watchface (created with WFS 1.5.7 in Watch Face Format) works just fine. Is this about the older watchfaces for Wear OS 2?

My battery and Fitbit (steps and distance) complications work as well.

If you provide a Play Store link for a broken watchface, I’d test it and post my results here.

I can confirm this one. My watchface cannot be configured on the Google Pixel Watch app. You can still configure it on the smartwatch itself though.

This worked a month ago on the Wear OS 4 Preview emulator so I guess Google broke something in their own app.

1 Like

Hi. Please test this one Athlete 2 Lite
Users are reporting than [SC] tag is not working when steps count is higher than 1000. Looks like the same issue from the Pixel Watch release.

Also, customization options are named like “Option1, Option2” - this is most probably caused by bad watchface.xml generated by Watch Face Studio.

@sinjae , @catherina00
Is there any plan to update WFS with correct watchface.xml generated sooner than before Q1/2024?

1 Like

The step counter doesn’t work at all for me. It either shows 0 or the placeholder 3457. See the correct step counter in the top left complication.


Can confirm the option localization issues. The title is there but all options are unnamed.

image image image

How did you get these layout options anyway in WFS 1.5.7? I can’t have options besides the color palette.

1 Like

See @Knightwing answer. You can also set preview images in the Customization Editor.



Hasn’t this always been the case for Pixel watches If I recall right they return a string 1.1k or something like that. Maybe that was just the complication.

In Samsung Health there is an setting to share with health services. Could it be that you need to set that in the Pixel watches?

Samsung Developer Relations

1 Like

Hi Ron, maybe yes. In the last few months I did not receive any complaint from Pixel Watch owners so I thought that it wax fixed.

Maybe there is similar setting in their Fitbit app but I don’t think that it will help with the issue. Google is doing it correctly because 6,5K is better for complication than 6500 (Short Text). Problem is that they are also reporting this string to the system steps counter which is used by [SC] tag.

1 Like

Can you confirm that on Google Pixel 2 the pre-installed shortcut to open the “Heart Rate” app does not launch anything. Clients write to me that when they tap on the heart label, nothing happens. But on my Samsung Galaxy, the shortcut successfully launches the “heart rate” application.

1 Like

What exactly do you mean by “heart label”? Both small and large heart rate complications launch the Fitbit app just fine.

However, you must login with your Fitbit account on the smartphone before the app becomes useable. Even the heart rate app. Maybe your client misstook that as “does not launch anything”?

1 Like

Thank you for information. I will write to the client about the fact that he needs to log into Fitbit.

1 Like

Hi everybody,
I have customers reporting that steps count doesn’t work on Pixel smart watches, mainly Pixel Watch 2. I only use [SC] as my main tag for the steps count. The down side is KCAL and distance are also calculated based on the steps count, so all of them do not work. I’ve told them to log into the FitBit app on their smartphones and try it again, but I am unsure if this will solve the issue. Unfortunately, I do not have a Pixel Watch to test it myself. If anybody is interested, I can provide you with the watchface to test on your Pixel Watch and would really appreciate your feedback.

Solution is actually to log out of Fitbit app but it only works for some models. Problem is in how Fitbit is reporting steps value to the watch.

This should be fixed with November security patch.

Like I predicted, logging into FitBit doesn’t solve the issue.
Deleting and reinstall did not do the trick as well.
I thought there might be a problem with an animation so I tried replacing the animation with an image sequence.
I’ve asked people to log out of FitBit and give it a try.
I will post the results here as well.

I believe these issues emerged with the latest update of the Galaxy Wearable application. Additionally, ranged value complications are also not functioning.

@ozan , this is about Pixel Watch 1/2.

Galaxy Wearable has it’s own set of issues after latest update. Created issue report 7 days ago, after like 4 days they noticed there is some issue report. Let’s see what happens. Best thing is that they make core part of watch face customization not functioning and they don’t care at all. Are they even making some test before pushing app to production? Unbelievable…

And here, the result:

I also have poor reviews coming in and for some reason some customers do not believe in my explanation. Some even call me a scammer… all for something I cannot control.

Whats interesting is a few customers claim that they resolved the issue by tinkering with FitBit settings, but cannot explain how.

I cannot unpublish the watchface as users other than Pixel watch don’t seem to experience problems.

I have created a new topic for the recent Complications not showing issue.

@windlea @ozan

I would suggest you might put a note in your product description saying that the step count does not work with some Fitbit default settings, or something like that.

Is this that old bug where Pixel watches return 1.xx K after 10,000? Or does it not work at all?

Samsung Developer Relations