Preferences panel not opening in Mac Catalina

Hello everyone!

I’m using GWD about 2 hours making a watch face and learning. I want to add weather in it and already create an account in OpenWeather and get my API key. When I try to open preferences panel in GWD in Mac OS Catalina, it does not open. I already closed and opened the application several times and nothing.

Someone experienced this?

Hi Ale,

What version of Java are you using I’ve seen issues on the Mac that were solved using Java 11.

There is a program called eclipsec that is in the same folder as GWD/GWS and it launches GWD or GWS and creates a log. You may want to run that program and see if the log shows a problem with opening preferences.

Finally if you create a support request and include the log as well as OS Type and version of GWD/GWS you are running they should be able to help you.

Samsung Developer Program

Hi @r.liechty_SDP thanks for the answer!

I’ve tested with java 8 and 14 but get the same error.
I’ve opened the application through it’s executable file in MacOS folder and it’s opened through Terminal. Every menu I clicked it logs a ‘menu shown’ in Terminal, but when I click Galaxy Watch Studio menu to open Preferences it’s logs nothing.
In Eclipse folder I’ve not found an executable not even a log file (print).

MacOS version: 10.15.5 (Catalina)
GWS version: 2.0.0_beta (build 200403)

Note: I’ve created a support request but, even though I did, I put the same answer here because can help others with the same problem.


Screen Shot 2020-06-13 at 12.53.09


I found a note and it said
The problem with the preferences not showing on Windows is the scaling for HD monitors.
I don’t know at what point it won’t work but it certainly won’t work above 150.

Samsung Developer Program

I’m using Mac OS with a LG ultrawide monitor. It’s just 1080p.


It might be the ultrawide monitor mention that in your support request. I have asked that I be copied on that by the GWS support team.

Samsung Developer Program

Hi Ron, I get the same problem on my Macbook (no monitor, just using the Macbook’s screen). The Preferences screen does not appear.

Macbook Pro (15 inch, 2018)
macOS 10.15.6
Built in display 15.4 inch (2880 x 1800)
GWS 2.0.0_beta
Build: 200403

I think this is an issue with scaling if it is greater than 1.5 lower it.

The easiest way is to hold Alt when you click on the Scaled option, which will force macOS to show the additional scaled resolutions in the list.

Samsung Developer Program

not sure if this is what you are looking for… I’m on Catalina as well, the PREFERENCES doesn’t open under the GALAXY WATCH STUDIO drop down menu, but does from the EDIT drop down…

Hi @ale1591986253 and @jao1596910877,

Did you check this out yet. I found the PREFERENCES is also appeared nicely from the EDIT drop down on my MacOS (Catalina).