Galaxy Watch Studio won't launch

Why is nobody fixing this issue? I’m on a Mac with Big Sur 11.3, GWS opens up a blank white screen and just freezes. I’ve been reading posts about this issue that are at least six months old and nothing I tried worked (changing info.plist or my eclipse.ini). Am I missing something or did you for real not manage to fix this ever since?

I also tried installing Tizen Studio - the installation program won’t let me accept the terms and just won’t react to any clicks. Ridiculous.

Apples decision is that using JRE of any sort is a security issue. Tizen Studio worked on 11.3 but something in 11.4 broke Tizen Studio installer. Are you sure you are on 11.3?

As for GWS when it was released it was compatible with macOS Catalina but I’m not allowed to say anything more at this time.

Samsung Developer Relations

So the official response to anyone wanting to use GWS on a mac is use an OS version that is two years old?

One user has found a way to do it. Galaxy Watch Studio and Mac Big Sur Update - #117 by SGWatchDesign It is not something that Samsung could do in an installer.

Be sure to read the previous postings by the user and any following. I think he tweaks the method.

Samsung Developer Relations

Thanks, but unfortunately, even after being actually able to install it now, I cannot connect to the watch and I’ve tried 2 wifis, developer mode and the suggested terminal command. This whole thing is just absolutely embarrassing - one of the biggest tech companies in the world isn’t able to provide users with the possibility to create watch faces for one of it’s most popular wearables.

Sigh, this is a bug in GWS for 2 years and so common I forget about it. Open a support request and ask for the Tizen SDB for Mac OS they should provide it for you. If they don’t…

install Tizen studio 4.1.1 and note where it installs to.
Open the location of Tizen Studio “tizen-studio” folder.
Open the “tools” folder within this folder.
Note the “sdb” program
Now find your GalaxyWatchDesigner in the MacOS Applications folder.
Right click on the file and choose “Show package contents”
Open the “tizen” folder
Open the “tools” folder
Drag the Tizen Studio sdb version of the file and drop in in the tools folder of the package tools folder overwriting the other sdb file.
Close the package
Now you run the designer, it will connect without the sdb error.
Keep a copy of this good sdb file in a safe place just in case you need to do this again after the next update.

On the one side I really appreciate the help, on the other side, this is such a f**ing sh*t show I’m actually impressed. I now managed to use the sdb file and get GWD to connect to my watch, but every time I try to generate a certificate I get a “warning - timeout” or “read time out”. WHAT THE F IS WRONG WITH THIS???

Certificate signed - now the app freezes before sending watch face to watch because it is unable to save any files. f this.

I agree it and I am highly impressed with your resilience. Apple believes that Java is a security risk and GWS is based on the Java based Eclipse IDE.

Thank you for your patience.

Samsung Developer Relations.