Galaxy Watch Studio and Mac OS Big Sur

Hello. I have the following problem. I updated my iMac to MacOS BigSur today. After the update, I wanted to start the Galaxy Watch Studio. The start screen appears and after a short time a white program window with no content appears. Who can help!?

Sorry for my bad english.

2 Likes

Hi @SGWatchDesign,

Try to re-install GWS and see what happens. If the issue is specific and consistent then submit a support request.

Azad

I’ve already done it, also installed the latest Java version. nothing helped. I have already created a support request

Same thing is happening with me as well. I also have reinstalled but same issue done some changes in info.plist but nothing worked for me… Hope to see any solution for this…

Add a third person who has this exact problem.

I also am having the same issue.

I think we all face the same issue… Not sure if it is because of GWS or Java or both…

Java is working fine Android Studio and Eclipse both are working fine. Only Samsung apps are making issues like Tizen Studio and Galaxy Watch Studio both are not launching on Big Sur.

hi, I had a support request from Samsung about this bug. I got this answer. Maybe someone can try this? I’m currently at work and can’t try it until tomorrow.

Thanks for reaching out to us.

Please share the following information with us to investigate the issue,

  1. Go to Applications/GalaxyWatchStudio.app/Contents/MacOS and run the GalaxyWatchDesigner executable file.
  2. It will open the terminal and run GWS. Please take a screenshot of the information shown in the terminal.
  3. Go to your home directory and find GearWatchDesigner folder. Share the wtahcface.log file with us after completing the previous steps.
  4. Version of your MacOS Big Sur.
  5. Java version on your Mac

Looking forward to your cooperation.

Regards,
Jakia Sultana
Samsung Developer Program Team

@SGWatchDesign here are the ss and log file
watchface.log (2.6 KB)

1 Like

you can send this log file and the other information ( 1. Version of your MacOS Big Sur.
2. Java version on your Mac) to

support@samsungdeveloper.zendesk.com.

I hope when many report it that something changes

@SGWatchDesign Okay, i have emailed them the screen shots, log and other information…

Okay thanks, I’ll send it tonight too

For others
Please add the following into /Applications/GalaxyWatchStudio.app/Contents/Info.plist inside the array tag under the Eclipse key

-vm/Library/Java/JavaVirtualMachines/jdk1.8.0_201.jdk/Contents/Home/bin/java
If your jdk version is not ‘jdk1.8.0_201.jdk’ then replace it with the version number of your system.

Ron
Samsung Developer Program

@r.liechty_SDP It doesn’t work that way either, Same issue still present even after updating the info.plist…

Hi Ron, I tried that as well… It didn’t work for me either!

Changing the info.plist did not work for me either. I’ve tried pointing to multiple different java locations on my machine and none work. Any update on other fix attempts?

I think we need to wait for an update from Samsung. It seems strange to me because the BigSur beta was available for long time now…

Before we faced problems with Catalina on connecting to the watch, a bit later it wouldn’t recognize some TTF fonts, now it doesn’t work at all! I think i am gonna downgrade!

I’ve sent all the data to support and I’m back to Catalina

Hi Silvio Kopf,

Thank you for sharing these information.
We have shared this issue with respective team. Whenever we get any feedback from them, we will let you know.

Looking forward to your cooperation.

Regards,
Jakia Sultana
Samsung Developer Program Team