Run On Device Error "Build Fail"

I for some reason keep getting a error that reads “Build Fail” when I try running on device. It seems to be only doing this with one of my watch faces. I restarted my computer, and watch.

All I did, was change the font files in it.

In my limited experience usually the Font missing come up as an error message but not always.

Make sure they are TTF fonts and not OTF or Mac TTF fonts. Some fonts will not run on the device If it gives a can not install error that is the issue.

Finally be sure that the fonts are installed on your computer and a copy of the font file(folder) is either in a folder in the project path or a short cut to the font is in the path.

If all seems right try a separate build first and see if it will then run on device.

Ron
Samsung Developer Relations

1 Like

Ok, I tried using the font on another watch face, works fine on other watch faces. So the probably has something to do with that particular watch face.

When I go to build the application, a error comes up “Image file does not exist”.

Look in the main.log file and it should say what image was not found. The dump file is not with WFS nor in the Workspace folder but in
Windows : C:\Users{User}\AppData\Roaming\watchfacestudio\dump\main.log
macOS : /Users/User Name/Library/Application Support/watchfacestudio/dump/main.log

Ron
Samsung Developer Relations

1 Like

Ok, found the images, replaced them, and it seems to be working again. Tho, my watch doesn’t prompt me, when it connects anymore. lol

It’s funny that a missing image can cause a problem.

I’m glad id worked, this was pretty common in Galaxy Watch Studio.

I don’t know what triggers the allow debugging prompt I thought it asked the first time after you enabled debugging but maybe it is cached like the RSA Encryption key was for Tizen OS.

Ron

1 Like

today im still facing this non sense bug of image file does not exist. where as when i extracted the wfs the file mentioned in dump log exists.

it is a background shade layer. i deleted the layer but i still get this non sense error. I added every image present in the watch face again , deleted the mentioned file misssing layer but i still cannot fix this crap.

WFS cannot hold its crap together and keeps throwing this non sense error

[WatchFaceStudio][11:45:58 AM][C:\Program(BuildAab.js:273)] C:\Users\Osman\AppData\Local\Temp.WatchFaceStudio\74828991706305128146915562381011\res\drawable-nodpi\wfs_75_16f7546d_22a8_4d04_876e_9e829e031a65.png does not exist.

nothing is fixing this

Hi Osman,

Make a copy of your .wfs project
rename that copy to .zip and open it
find where that file is mentioned and delete it

Rename the copy .wfs again (as a different name than the original)
and see if that builds.

Ron

Did that didnt work. The wfs says invalid file and doesnt load the wfs file after deleting.

Looks like i have to do the watchface again from start.

HI Osman,

I don’t know what the issue is. If you are putting your resources in the AppData\ folder and that is causing a problem or it is a file naming issue wfs_75_16f7546d_22a8_4d04_876e_9e829e031a65.png seems like an odd name.

I’d suggest in your C:\Users\Osman\watchfacestudio\workspace folder you create a library folder and organize your resources in that. They certainly should not be in the AppData folder… but that just may be where they are held temporarily when the project is loaded…

Sorry I can’t be of help on this.
Ron
Samsung Developer Relations

Hi Osman,

I duplicated this. I was using a GWS image file as a background image. I uninstalled and installed GWS to an older version for some testing and then reinstalled it back to newer version and got the image does not exist message.

Deleting the background and reinstalling it from the same (replaced) folder and all built fine.

I don’t know how you chase the exact image down but if you did any file changes or moved any images that is probably the culprit.

Hope this helps

Ron

1 Like

Thanks Ron :slight_smile:

I fixed this and managed to rebuilt the watchface by deleting every image and a heart rate animation. Then i added them back again. Nothing else worked for me.

I noticed in change long first animation images, deleted the animation, still wont work and then showed build fail due to another image’s style image file missing.

So for me deleting every image and adding them back. Without deleting the text layers present worked

what does this mean? I just found this in the log and have been waiting for the new update but figured I try again and found this in the log.

[WatchFaceStudio][6:19:20 PM][undefined(adb.js:133)] Something went wrong: Error: spawn adb ENOENT
at Process.ChildProcess._handle.onexit (internal/child_process.js:269:19)
at onErrorNT (internal/child_process.js:465:16)
at processTicksAndRejections (internal/process/task_queues.js:80:21)

This says the java script that launches adb (Android Debug Bridge) can’t start it. That error message may have been from weeks ago. The dates in the log are pretty much non-existent. But there is a bug that after starting the computer you need to basically select run on device quit and then launch WFS again to connect.

If you can’t connect to the w3atch restart the Watch Face Studio. For some reason when you try to run on device the first time WFS does not find the adb but it does connect to the device. Closing WFS and restarting it does see adb is connected and will then run on Device.

Ron
Samsung Developer Relations

This was a bug introduced in V1.0.12 I know they are beta testing a new release but they may find a last minute bug or wait for a firmware update so I don’t know how soon it will be released.

Ron
Samsung Developer Relations

My issue with WFS 1.1.9 is “Run on Device”. It keeps running to no end. After awhile I have to force quit and start over. If I’m lucky it would prompt something like “Run on Device failed”.

Are you saying it connects to your device you see the Watch run on device window, you click on it and then it just spins and spins?

If so when you click on the device does the allow debugging pop up on your watch and do you allow it?

If not go to your developer Options settings and revoke all debugging permissions (right after adb debugging) and then try again that should force the allow debugging pop up on your watch when you select the device in WFS.

If that isn’t it please open a different topic or point me to your other topic on this so I can help you a bit better without other clutter.

Ron
Samsung Developer Relations

OK, I will do that and give it another try. Thanks.

It’s working fine now Ron after “revoke all debugging”. Thank you your awesomeness :pray: