Build Error Tried multiple uninstall and install Help (Solved Java issue sorry for the trouble)

Been constantly getting this, couldn’t even get a design to build on my watch :frowning:
Please help

same here any help?..

How did you solve it?

I’m having this same issue: “Resource are not found.”

If anyone has solved this, please explain how it was solved. Thanks!

Build a sample watch face to be sure it isn’t something in the system.

Resource not Found is one of two issues one is lacking an AOD and since you have an AOD that isn’t it.

The other more common is an image or font that is missing.
Close GWD, make a copy of the .gwd file that won’t build
rename the copy to .zip and open it.
Look at the res folder for resources
Open the resource.xml or the watchface.xml and you will probably find one resource that is included that is missing or corrupted in the folder.

Samsung Developer Relations

I get the same error for sample projects. What sort of system issue could cause that?

Found the issue - it’s a bug in GWS 2.0.1. It’s not a missing resource at all, but rather a Java version mismatch.

I originally installed 2.0.1 so I could use it on Mac OS Big Sur, but it’s too broken. So I installed 2.0.0 on an older Mac running High Sierra and got the proper error when I tried to build. Turns out it’s a Java issue.

I had to uninstall JDK 17 and dig up and install JDK 14.0.2. Now it works!

HI Daaron,

If it comes up again I’ll let people know.

Be sure to back up all projects the 2.0.1 release removes the AOD from the project file when it updates it.

Of course now Macos Monterey is coming so the cycle may start all over again.

Samsung Developer Relations