Run on Device Watch not found on WiFi Network

Hello All,

I’ve tried everything I could find to try and run my first watchface on my Galaxy Pro 5 Watch but the application does not find the watch. I’m trying to connect via WiFi.

Debugging is turned on on the watch.
The laptop and watch are both on the same network (I can ping the watch from the laptop)
I’m running Mac OS Monterey 12.6.

I also tried SDB over BT but the phone is not recognized via USB on the Mac (not sure why). I’d prefer to get it working over WiFi but at this point, I’ll be happy for it to just work.

Thank you in advance for any assistance anyone can offer.
Regards!
Feelics

Hello,
This is Tizen OS forum. Your issue is Wear OS issue. You can check the Watch face Studio forum.

Please follow the steps below to connect your watch to PC using debug over Wi-Fi:

  1. Connect the watch and laptop to the same Wi-Fi network.
  2. Turn on the development mode in the watch (Settings->About watch->Software->Software version (tap 5 times on software version))
    ** After tapping 5 times on the software version, a text appears that development mode is on
  3. Turn on ADB debugging mode for the watch (Settings->Developer options->ADB debugging).
  4. Turn Debug over Wi-Fi
    **If the IP address shows in the ADB Debugging → Wi-Fi, then it is connected, it always takes a minute for the connection and says unavailable until it connects.
  5. Click the run-on device button in Watch Face Studio.
  6. If your watch does not show on the list put the IP address (watch IP address) in the connection box.
  7. Select the watch and deploy your watch face.
    Let me know if you face any issue to connect.

Hello,

Thank you for your reply! I actually found a post last night and tried it with Watch Face Studio and it is working great! I didn’t have a chance to post anything last night!

Again, thank you for your help and reply!

Regards,
Felix